Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПАСКАЛЬ, строка символов

10-11 класс

Напишите программу, которая:
а) определяет, сколько раз встречается в строке символ 'A'
б) заменяет символ 'А' символом ' * '
в) удаляет из строки символ 'В'
Пожалуйста, помогите! :с


Tema4321 13 июля 2015 г., 0:29:42 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hockeyist17
13 июля 2015 г., 2:52:38 (8 лет назад)

а)Program z1;
Var S:string;
i,n,d:integer;
Begin
read(s);
d:=length(s);
n:=o;
For i:=1 to d do
If copy(S,i,1)='A' then
n:=n+1;
writeln(n );
End.

+ 0 -
Remixx
13 июля 2015 г., 4:22:49 (8 лет назад)

program proga;
var str:string;
i,counter,pos:integer;
k:char;
a:array[1..255] of char;
begin
k:='*';
counter:=0;
writeln('Введите строку');
readln(str);
for i:=1 to length(str) do begin
if str[i]='А' then begin
inc(counter);
Delete(str,i,1);
Insert(k,str,i);
end;
end;
writeln('Количество символов А ',counter);
for i:=1 to length(str) do begin
a[i]:=str[i];
if a[i]='В' then
a[i]:=' ';
write(a[i]);
end;
end.

Ответить

Другие вопросы из категории

Написать

функцию, которой передаются координаты точки (x, y) и которая определяет,
попадает ли точка в заштрихованную область на рисунке через PHP

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. С клавиатуры вводится целое число X. Опишите на

русском языке или на одном из языков программирования алгоритм, который находит и выводит наименьший номер элемента, равного X, или сообщение, что такого элемента нет.
const N=30;


var a: array [1..N] of integer;


i, j, x: integer;

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

дана строка символов

Сколько раз среди данных символов встречаться цифра?
паскаль. подскажите

Помогите решить задачу в паскале.Дана

строка символов р1, р2,
..., рn. Определить число вхождений в последовательность группы
букв "xyz". Вырезать
фрагмент из текста между первым и вторым вхождением группы символов "xyz".

Помогите пожалуйста!!!СРОЧНО!!! Прошу!!!Написать программу в паскале!!!

Составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. Замена выполняется, начиная с заданной позиции строки.

Паскаль:

1) дана строка символов, в которой есть хотя бы вхождение 'abc'. Все вхождения 'abc' заменить на 'def'

2) в заданном тексте все встретившееся буквы 'a' удалить, а буквы 'd' удвоить



Вы находитесь на странице вопроса "ПАСКАЛЬ, строка символов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.