Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Привет, мне нужна помощь . 1 задание. Программа в паскале

10-11 класс

PQPRQOOU 09 авг. 2015 г., 22:10:04 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivan7771
09 авг. 2015 г., 23:30:33 (8 лет назад)

uses crt;
var a,b:integer;
c:boolean;
at,bt:string;
begin
write('Введите числа А и В: ');
readln(a,b);
if ((a mod 2)=0) or ((b mod 2)=0) then begin
str(a,at); str(b,bt);
a:=length(at); b:=length(bt);
if (copy(at,a,1)<>'2') or (copy(bt,b,1)<>'2') then c:=true else c:=false;
end;
writeln(c);
end.

Т.к. число может быть любым по длине, числа, кратные двум, переводятся в текст и затем уже проверяется, двойка у них на конце или нет.

Ответить

Другие вопросы из категории

Help! Помоги написать программу.

Нужно ввести с клавиатуры число N и если оно четное, то найти его факториал, а если нет то нужно вычислить сумму 1+2+...+N. С факториалом я более менее нашел решение, а прогрессию не понимаю.

ПАСКАЛЬ, строка символов

Напишите программу, которая:
а) определяет, сколько раз встречается в строке символ 'A'
б) заменяет символ 'А' символом ' * '
в) удаляет из строки символ 'В'
Пожалуйста, помогите! :с




Вы находитесь на странице вопроса "Привет, мне нужна помощь . 1 задание. Программа в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.