Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое положительное число А, значение которого вводится с клавиатуры. Напишите программу, позволяющую:

5-9 класс

- найти минимальную цифру среди последних трех цифр числа
- вывести на экран найденную цифру
- если цифр меньше трех, то выдать сообщение < невозможно выполнить заданную операцию>. программу выполнить в pascal abc. спасибо!

Sonyapavelevs2 27 янв. 2017 г., 11:48:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dooble221
27 янв. 2017 г., 13:29:52 (7 лет назад)

uses crt;
var x,y,i,n,s,min:longint;
m:array[1..100] longint;
begin
clrscr;
readln(x);
i:=0;
while x<>0 do
begin
i:=i+1;
m[i]:=x mod 10;
x:=x div 10;
end;
min:=m[1];
if i<3 then writeln('Error') else
begin
for y:=1 to 3 do
if m[y]<=min then min:=m[y];
writeln(min);
end;
readln();
end.

Ответить

Другие вопросы из категории

Напишите программу в среде программирования Турбо Паскаль, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных

3. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

Читайте также

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

В трехзначном числе x зачеркнули его вторую цифру. Когда к

образовавшемуся двухзначному числу справа приписали вторую цифру числа x, то получилось число n. По заданному n найти число x
(значение n вводится с клавиатуры).



Вы находитесь на странице вопроса "Дано целое положительное число А, значение которого вводится с клавиатуры. Напишите программу, позволяющую:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.