Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

НАРОООД, СРОЧНО!

5-9 класс

Составить 2 программы в Паскале.
Петя положил в банк N рублей. каждый месяц банк начисляет 3%..
1) сколько денег будет через К месяцев

Loserrr 11 сент. 2014 г., 20:14:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Morefuninlif
11 сент. 2014 г., 22:55:51 (9 лет назад)

const p = 0.03;
var 
  n, z, m: real;
  k, c, i: integer;
begin
  write('Введите n (руб): ');
  readln(n);
  
  // первая
  m := n;
  write('Введите k (мес): ');
  readln(k);
  for i := 1 to k do
    m := m * (1 + p);
  writeln('Через ', k, ' мес. будет ', m, ' руб.');
  
  // вторая
  k := 0;
  write('Введите z (руб): ');
  readln(z);
  while n < z do begin
    n := n * (1 + p);
    k := k + 1;
  end;
  writeln(z, ' руб. будет через ', k, ' мес.');
end.

Ответить

Другие вопросы из категории

сторона, передающая информацию
Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

Пользователь работал с каталогом

D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА. Сначала он поднялся на три уровня вверх, потом спустился в каталог ИНФОРМАТИКА. Укажите полный путь для того каталога, в котором оказался пользователь (запишите номер правильного ответа):

1)D:\ДОКУМЕНТЫ\ФОТО\ИНФОРМАТИКА\

2)D:\ДОКУМЕНТЫ\ИНФОРМАТИКА\ЭКЗАМЕН

3)D:\ДОКУМЕНТЫ\ЭКЗАМЕН\ИНФОРМАТИКА

4)D:\ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА\ЭКЗАМЕН\ИНФОРМАТИКА

Читайте также

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

ОЧЕНЬ СРОЧНО!!!!!!!

По каналу один за другим идут пароходы "Обь" и "Восток". Навстречу им идут один за другим пароходы "Мир" и "Енисей". Канал такой ширины, что два парохода в нем разойтись не могут. Но с одной стороны канал имеет расширение, в котором может поместиться один пароход. Как можно пароходам разойтись и продолжить свой путь?
Изобразите решение в виде схемы.ЗАРАНЕЕ СПАСИБО!(объясните,кто как может,очень срочно)

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

пожалуйста срочно помогите, очень прошу

тема у нас Организация ветвлений в Паскале. и так, вопрос:
дано трёхзначное число. если сумма цифр числа кратно 3, тогда перевернуть число, иначе обнулить среднюю цифру
очень срочно, кто может



Вы находитесь на странице вопроса "НАРОООД, СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.