Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

с помощью c++(с циклом while) дано натуральное число n вычислить 1*2+2*3*4+...+ n*(n+1)*...*2n

10-11 класс

Niki007 04 мая 2013 г., 5:01:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wenersd4
04 мая 2013 г., 7:37:47 (10 лет назад)

#include <iostream>
using namespace std;
int main()
{
int sum=0,i=1,n;
cin>>n;
while (i<2*n)
 
    sum+=i*(i+1);
    ++i;
}
cout<<sum;
}

Ответить

Другие вопросы из категории

помогите(((((!!!!!! Запишите логическое выражение для каждой из фраз:

А принадлежит диапазону (18; 80)___________________________________
А принадлежит диапазону [18; 80) __________________________________
А принадлежит диапазону (-10; 18) __________________________________
А принадлежит диапазону [-10; 18] _________________________________
А не принадлежит диапазону [-10; 18]_______________________________
А не принадлежит диапазону (-10; 18) _______________________________
А меньше -1 или больше 1_________________________________________
А не принадлежит диапазону [18; 80) _______________________________
А больше 0 и не равно 10__________________________________________
А кратно 4 и 5 (используйте mod)__________________________________

Даны следующие типы данных:

type Date = record

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается

на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

2. Дано натуральное число



Вы находитесь на странице вопроса "с помощью c++(с циклом while) дано натуральное число n вычислить 1*2+2*3*4+...+ n*(n+1)*...*2n", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.