Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте пожалуйста программу S=x/2+2x/3+3x/4+(n-1)/n

5-9 класс

Rimulya1 20 дек. 2014 г., 2:18:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Duska99
20 дек. 2014 г., 2:59:04 (9 лет назад)

var

  S, summa, x: real;

  n, i: integer;

 

begin

  s:= 0;  //Присваиваем начальное значение переменной s

  writeln('Введите x');

  readln(x);

  writeln('Введите n');

  readln(n);

  for i:= 2 to n do  

  begin

    summa:= ((i - 1) * x) / i;  //Вычисляем значение суммы при текущем i

    s:= s + summa;  //Складываем его с общей суммой

  end;

  writeln('s = ', s : 0 : 5);  //Округляем до 5 знаков после запятой

end.

 

Ответить

Другие вопросы из категории

1. Продолжите ряд: i486, Athlon, Pentium, Celeron, ... А) Core i7 Б) CoreIDRAW B) Counter-Stike Г) Corrado 2. "Если

сохранит Ctrl+S, то поможет ...". С точки зрения программного обеспечения, вместо многоточия можно вставить, как наиболие часто используемое, ...

А) F1 Б) F2 B) F3 Г) F4

решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18,

r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.



Вы находитесь на странице вопроса "Составьте пожалуйста программу S=x/2+2x/3+3x/4+(n-1)/n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.