Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Очень сложная задача по информатике которую нужно записать на Pascal !!

5-9 класс

Lenoleum 26 янв. 2014 г., 17:37:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sascha123q
26 янв. 2014 г., 19:49:20 (10 лет назад)

var
  x1, y1, x2, y2, i: integer;

begin
  Write('Введите через пробел исходные номера улицы и авеню: ');
  Readln(x1, y1);
  Write('Введите через пробел конечные номера улицы и авеню: ');
  Readln(x2, y2);
  Writeln('Найденный путь:;');
  if x2 > x1 then for i := x1 to x2 - 1 do Write('E')
  else for i := x1 downto x2 + 1 do Write('W');
  if y2 > y1 then for i := y1 to y2 - 1 do Write('N')
  else for i := y1 downto y2 + 1 do Write('S');
  Writeln
end.

Тестовое решение:

Введите через пробел исходные номера улицы и авеню: 1 3
Введите через пробел конечные номера улицы и авеню: 4 1
Найденный путь:;
EEESS

Введите через пробел исходные номера улицы и авеню: 58 49
Введите через пробел конечные номера улицы и авеню: 36 23
Найденный путь:;
WWWWWWWWWWWWWWWWWWWWWWSSSSSSSSSSSSSSSSSSSSSSSSSS


Ответить

Другие вопросы из категории

Плиз помогите сделать!!!
Работа с програмой paint на windoes xp можно на windoes 8

Чтобы выбрать фоновый цвет, необходимо ...

Программа выполняется в Паскале! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, им

еются ли в записи числа N нечетные цифры. Если имеются, то вывести True, если нет — вывести False. Помогите плииз.

Читайте также

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))

Пожалуйста, решите задачи по информатике , прошу ,очень срочно нужно а то за четверть будет плохая оценка ! Вот задачи : 1. Данны два массива из 10

элементов. Получить третий, элементы которого равны сумме соотвествующих элементов первого и второго массивов. (Qbasic)

помогите решить задачи по информатике 1 сообщение занимает 2 страницы по 25 строк в каждой строке по 45 символов сколько символов в используемом

алфавитеесли сообщение содержит 2000 байт ? 2 объем сообщения содержащего 2048 символов составляет 1\512 часть мбайта какова мощность алфавита с помощью которого записано сообщение ?

ПОМОГИТЕ ПОЖАЛУЙСТА

ОЧЕНЬ СРОЧНО
задача за 8 класс , нужно сделать по типу "фри паскаля "
Составьте программу, которая будет запрашивать стоимость за покупку ,сумму денег ,внесенную покупателем в кассу ,далее определяет причитывающеюся ему сдачу (если денег внесено больше ,печатает "Спасибо"(если сдачи не требуется,или выдает сообщение о недостаточности внесенной суммы

Помогите с 1 задачей по информатике, пожалуйста. Она вполне лёгкая и маленькая. Но что-то я не как не могу разобраться с ней.

Задача:

-"Определите количество информации в изображении-которое состоит из 600строчек, и когда в 1 строчке = 800точек. Тоесть 800точек/1строчку. И если глубина цвета=4бита."

P.S. Заранее спасибо ответившим! :)



Вы находитесь на странице вопроса "Очень сложная задача по информатике которую нужно записать на Pascal !!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.