Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157=751

10-11 класс

Kristy979797 06 июля 2013 г., 8:41:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PuПsИk
06 июля 2013 г., 9:20:04 (10 лет назад)

Интересная задачка, заковыристая...

Var x,i,c,q,p:integer; s:string; max,min,k:char;
Begin
 readln(x);
 str(x,s);
 max:=s[1];
 min:=s[1];
 p:=1; q:=1;
 for i:=2 to length(s) do
   begin
    if s[i]>max then
      begin
       max:=s[i];
       q:=i;
      end;
    if s[i]<min then
      begin
       min:=s[i];
       p:=i;
      end;
   end;
 k:=s[p];
 s[p]:=s[q];
 s[q]:=k;
 val(s,x,c);
 writeln(x);
End.

Сработает для чисел любой значности.

Ответить

Другие вопросы из категории

составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная

матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.

Читайте также

дан вектор b[1:10] а)найти минимальный и максимальный элементы вектора.,)поменять местами максимальный и минимальный элементы. в)получить сумму

элементов между их номерами.г)Получить произведение отрицательных элементов. Помогите пожалуйста.

Помогите пожалуйста решить))) или хотя бы натолкнуть на мысль )) 1) Записать элементы массива Х, удовлетворяющие условию 1≤Xi≤2, подряд в массив

Y. Поменять местами максимальный и минимальный элементы в массиве Y.

2) Заменить строку матрицы Р(n,m) с минимальной суммой элементов на строк, где находится максимальный элементы матрицы.

3) Определить, пересекаются ли параболы у=ах2+bc+c и y=dx2+mx+n. Если пересекаются, то найти точку пересечения.

Составить программу в PASCAL.

Вводится длина вектора и значения его элементов.
1. Подсчитать количество элементов, равных заданному значению.
2. Поменять местами максимальный и минимальный элементы вектора.
3. Подсчитать количество отрицательных, положительных и нулевых элементов вектора.



Вы находитесь на странице вопроса "Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157=751", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.