Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

СОСТАВИТЬ ПРОГРАММУ В ПАСКАЛЕ ПОЖАЛУЙСТА ПОМОГИТЕ!

10-11 класс

двум приятелям родители подарили по новому мотоциклу .подростки поспорили кто быстрее пройдет обкатку двигателя 2500 км. первый проехал километры за 12 дней, а второй в первый день проехал 150 км, а в каждый следующий он прибавлял 20 км. нужно разрешить их спор и выявить кто сделал обкатку быстрее

Дейлиус 02 марта 2014 г., 21:46:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tomaragimova
03 марта 2014 г., 0:02:43 (10 лет назад)

const
  s = 2500; {пробег для обкатки}
  n1 = 12;{число дней, потраченное первым подростком}

var
  s0, s2: real;
  n2: integer;

begin
  s0 := 150;
  n2 := 1;
  s2 := s0;
  while s2 < s do
  begin
    s0 := s0 + 20; {ежедневный пробег}
    s2 := s2 + s0;
    n2 := n2 + 1
  end;
  if n2 > n1 then Writeln('2-й подросток завершил обкатку позже на ', n2 - n1, ' дн.') 
  else if n2 = n1 then Writeln('Оба подростка завершили обкатку одновременно')
  else Writeln('2-й подросток завершил обкатку раньше на ', n1 - n2, ' дн.')
end.

Решение:
2-й подросток завершил обкатку раньше на 1 дн.


+ 0 -
Rudik313
03 марта 2014 г., 0:46:37 (10 лет назад)

Т.е во второй день он проехал 150+20=170 км, в третий 170+20=190 км... а всего 150+170+190+... пока 2500 не набрал?

+ 0 -
Dronfifa
03 марта 2014 г., 1:21:51 (10 лет назад)

Комментарий удален

+ 0 -
Dashenkaclevergirl
03 марта 2014 г., 1:58:21 (10 лет назад)

Тогда все просто...

Ответить

Другие вопросы из категории

Помогите составить программу на языке PASCAL

В матрице X(5×5) определите произведение положительных элементов
главной диагонали.

В 1975 году джордж лукас приступил к созданию этого фильма. Он собрал команду одних из самых первых в киномире компьютерных фанатов и основал студию

цифровых и визуальных эфектов. Это фильм

А)"Армагедон" Б)"2001: Космическая одисея"

В)"Звёздные воины" Г)"Звёздный путь"

Читайте также

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:



Вы находитесь на странице вопроса "СОСТАВИТЬ ПРОГРАММУ В ПАСКАЛЕ ПОЖАЛУЙСТА ПОМОГИТЕ!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.