Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

РЕБЯТА ПОМОГИТЕ ПОЖАЛУЙСТА ПОМОГИТЕ ПОЖАЛУЙСТА!!НУЖНО РЕШЕНИЕ ЗАДАЧИ,ОТ РЕШЕНИЯ ЭТОЙ ЗАДАЧИ,ЗАВИСИТ МОЯ ОЦЕНКА. БУДУ ОЧЕНЬ БЛАГОДАРНА

5-9 класс

Создать целочисленный массив из 15 чисел. Заполнить с помощью генератора случайных чисел с элементами от -15 до 30. И вывести его на экран. Определить самый большой элемент массива и его индекс.
A (i):=random (x) -15
от -1 до х
от -15 до 30.

Nekitaverin 03 февр. 2014 г., 12:54:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
граф555
03 февр. 2014 г., 15:11:25 (10 лет назад)

uses crt;
var a, b, c, i, n, j :integer;   

s :array[1..10000] of integer;
begin
      clrscr;
      writeln('Введите размер массива');
      read(n);
      for i:=1 to n do 
          begin 
          s[i]:=random(46)-15; 
          writeln ('s[', i,']=', s[i]); 
          end;
      a:=s[1];for i:=1 to n do 
          if s[i]>a then 
              begin 
              a:=s[i]; 
              b:=i; 
              end;
      writeln ('Наибольший элемент s[', b, ']=',a);
end.

P.S. Надеюсь на благодарность и лучший ответ.

Ответить

Другие вопросы из категории

1)среди 15 чисел найдите сумму всех положительных чисел

2) среди 15 чисел найдите количество всех чисел которые являются не отрицательными

Срооочно!!!

нужно составить программу на Паскале
на квадратное уравнение!

Составьте программу, позволяющую вставить слово t после первого слова исходной строки s. Строка s и слово t вводятся с клавиатуры. (PascalABC)

Пример ввода:
Наступила осень
золотая
Пример выводы:
Наступила золотая осень.

Читайте также

Какое количество информации содержится в слове ИНФОРМАТИКА, если каждый символ кодировать 1 байтом?

Объем информации сообщения 12288 бит(учитывая,что 1 байт=8 бит) можно выразить как? (задача на перевод информации выразить в Кбайт)

Буду очень благодарна!

Каждая клетка поля 5x5 кодируется минимально возможным и одинаковым количеством бит. Решение задачи о прохождении "конём" поля записывается

последовательностью ходов посещённых клеток. Определите объём информации в байтах после 15 сделанных ходов? Запись решения начинается с начальной позиции коня.

Помогиите, пожалуйста) ОЧЕНЬ нужно!

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Здравствуйте!Помогите пожалуйста с информатикой!

1.В ящике имеется 3 чёрных и 5 белых шаров.Какое наименьшее число шаров нужно взять из ящика ( не заглядывая в него), чтобы среди вытянутых шаров:.
1)Оказался хотя бы 1 чёрный
2)Оказался хотя бы 1 белый
3)Оказались хотя бы 2 чёрных
4)Окаазались хотя бы 2 белых
Если можно с решением,логическим рядом.
2. В одной книге было написано 100 следующих утерждений.
"В этой книге роно одно неверное утверждение"
"В этой книге ровно два неверных утверждения"
............................................................................................
"В этой книге ровно сто неверных утверждений.

Какое из этих утерждений верное?

Судя по моим мыслям,это явно не 3, тогда это получается правда, что противоречит смыслу предложения. Тогда какое получается? Я не знаю.Помогите пожалуйста. Напишите всё с решением пожалуйста.



Ах да,чуть не забыла. Если кто -то знает бесплатный решебник ( без всяких файлообменников) напишите пожалуйста.



Вы находитесь на странице вопроса "РЕБЯТА ПОМОГИТЕ ПОЖАЛУЙСТА ПОМОГИТЕ ПОЖАЛУЙСТА!!НУЖНО РЕШЕНИЕ ЗАДАЧИ,ОТ РЕШЕНИЯ ЭТОЙ ЗАДАЧИ,ЗАВИСИТ МОЯ ОЦЕНКА. БУДУ ОЧЕНЬ БЛАГОДАРНА", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.