Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

нужно ввести 3 значное число и поменять цифры например (345; 543) помогите пожалуйста

10-11 класс

Nathka 01 авг. 2016 г., 13:18:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veronikamadato
01 авг. 2016 г., 14:09:45 (7 лет назад)

если в паскале то...
program n1;
var x,a,b,c,k:integer;
begin
write('x='); readln (x);
a:=x div 100;
b:=x div 10 mod 10;
c:=x mod 10;
write ('k=',b,a,c);
readln;
end.
там где write ('k=',b,a,c) здесь a,b,c меняй местами и все)

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА!! PASCAL !

1. Составьте программу, вычисляющую, сколько букв надо исправить в слове Х, чтобы получилось слово Y (слова X и Y одинаковой длины).
2. Составьте программу, определения номера первой буквы "а" в слове Х.
3. Составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове Х чаще.

помогите пожалуйста!!нужно сделать в экселе
1.Дано целое

число А. Определить количество цифр в числе, которые больше 6.

Читайте также

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я

понял как
Console.WriteLine("Введите четырёхзначное число");
m = int.Parse(Console.ReadLine());
a = m / 1000; //последняя 1 цифра
b = m % 10;
допусти я ввёл число 6432 то прога выводит мне 6 и 2 мне надо ещё как то отдельно вывести цифры 4 и 3 и задать им отдельные переменные что бы сравнить

Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух

последних цифр заданного числа; 3) число, образованное перестановкой второй и четвёртой цифр заданного числа.



Вы находитесь на странице вопроса "нужно ввести 3 значное число и поменять цифры например (345; 543) помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.