Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Народ кто хорошо знает Информатику ???токо чесно решите програму на паскале)Составьте программу,каторая по задоннаму a исследует корни уравнения aх=5 и

5-9 класс

выводит на экран значение высленного корня либо сообщение "Корней нет"

Fanichka1998 06 янв. 2015 г., 3:50:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rekoo
06 янв. 2015 г., 4:48:42 (9 лет назад)

Сделаю операцию только с целыми числами.

 

Program fff;

label 1;

var a,y,x,i:integer;

Begin

 Writeln('введите а'); read(a);

 For x:=1 to 1000 do

  if a*x=5 then begin

             writeln(x);

             goto 1;

                      end;

Writeln('Корней нет!');

1: readln

end.

 

Алгоритм такой: проверяем выражение на равенство, если правильно, тогда пишем корень и заканчиваем программу. если цикл завершился, значит не одно число не совпало и мы пишем "корней нет".

Ответить

Другие вопросы из категории

Помогите пожалуйста

Решить уравнение ax+b=0. a и b вводятся с клавиатуры.
для паскаля

если сможете ещё и блок-схему.


/ИНФОРМАТИКА/ Решите пожалуйста, ОЧЕНЬ НУЖНО!!

1) Выведите на экран сумму и произведение всех чисел от 1 до 99.

1)В процессе преобразования растрового графического изображения количество цветов в палитре уменьшилось с 16 777 216 до 256. Во сколько раз при этом

уменьшился информационный объём изображения?
2) Какую часть экрана, имеющего разрешение 1024*768 точек, займет изображение файла типа BMP объёмом 1 Мбайт, созданного при глубине цвета, равной 32 бита?
3) После изменения свойств Рабочего стола монитор приобрёл разрешение 1024*768 точек и получил возможность отображать 65 536 цветов. Какой объём видеопамяти необходим для текущего изображения Рабочего стола?
Если возможно с развернутым ответом
Заранее ОГРОМНОЕ СПАСИБО!!!


Читайте также

помогите пожалуйста решить задачу в паскале: Составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е.

таким,которое читается одинаково слева направо и справа налево(например:23132).

Нароооооод!Кто смыслит в информатике,помогите пожалуйста решить номер один.Воть:сформируйте массив, содержащий 15 элементов ,с помощью датчику

случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.



Вы находитесь на странице вопроса "Народ кто хорошо знает Информатику ???токо чесно решите програму на паскале)Составьте программу,каторая по задоннаму a исследует корни уравнения aх=5 и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.