Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль! Найдите произведение целых чисел от a до b, где a и b вводятся с клавиатурыю

10-11 класс

Kbfdklbll 16 авг. 2014 г., 2:29:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Таня1987
16 авг. 2014 г., 3:07:57 (9 лет назад)


var a,b,i:integer;
proiz:real;
begin
proiz:=1;
readln (a,b);
for i:=a to b do
proiz:=proiz*i;
writeln (proiz);
end.

Ответить

Другие вопросы из категории

Написать в Паскаль программу для решения следующей задачи.

Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку , добавляя после каждого символа символ '0'.

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

помогите решить.паскаль1)найти сумму целых двузначных чисел.

2)найти произведение целых чисел от 3 до n

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99



Вы находитесь на странице вопроса "Паскаль! Найдите произведение целых чисел от a до b, где a и b вводятся с клавиатурыю", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.