Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задание 1. Создайте файл целых чисел F. Числа считываются с клавиатуры. Признаком конца

10-11 класс

ввода является число 9999.

Yurchalla 05 марта 2014 г., 15:03:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karelova530
05 марта 2014 г., 16:08:58 (10 лет назад)

var
  a: integer;

begin
  while (true) do
  begin
    readln(a);
    if (a = 9999) then
      break
    else
      System.IO.File.AppendAllText('F.txt', IntToStr(a) + System.Environment.NewLine);
  end;
end.

+ 0 -
Ammigadjiev
05 марта 2014 г., 17:29:10 (10 лет назад)

Эм... Для второй задачи с клавы считывать?

+ 0 -
діма0000
05 марта 2014 г., 18:05:20 (10 лет назад)

да можно и клавиатуры

+ 0 -
BitodelДан
05 марта 2014 г., 19:07:36 (10 лет назад)

короче как удобней

Ответить

Другие вопросы из категории

Определите значение переменной z после выполнения фрагмента алгоритма:

z:=1;
repeat z:=z+2 until z=10;


1) 9
2) 11
3) 10
4) 1
5) ни один из вышеперечисленных ответов не верен, мой ответ:


И в целом объясните) как то меня ввела в тупик эта задача)

Перечислите номера тех функций, которые относятся к логическим:

a. Мин
b. Макс
c. Сумм
d. Если
e. Не

Читайте также

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

1. Дан файл целых чисел. Преобразовать его, удалив

нечетные числа. Порядок следования четных чисел сохранить.Решите пожалуйста !

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого

интервала. № 2. Имеется типизированный файл с числами. Изменить все его элементы, порядковый номер которых кратен трем. Новые значения вводятся с клавиатуры. Размер существующего файла неизвестен.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.



Вы находитесь на странице вопроса "Задание 1. Создайте файл целых чисел F. Числа считываются с клавиатуры. Признаком конца", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.