Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль.двухмерный массив.

10-11 класс

В массиве B [1..10,1..3] содержатся данные о количестве сотрудников учреждения.Элементы первой строки обозначают номер отдела, элементы второй строки количество мужчин в нем,элементы третьей строки количество женщин в отделе.Сколько всего сотрудников в учреждении и кого больше: мужчин или женщин?

уникальная 01 июля 2014 г., 23:04:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shahid19585
02 июля 2014 г., 0:59:47 (9 лет назад)

var b:array[1..10,1..3] of integer;
i,j,k,s,gi,bo:integer;
begin
writeln('Исходный массив: ');
for i:=1 to 10 do
for j:=2 to 3 do b[i,j]:=random(30);
k:=1;
for i:=1 to 10 do begin
for j:=1 to 3 do
b[i,1]:=k;
inc(k);
end;
for i:=1 to 10 do begin
for j:=1 to 3 do write(b[i,j]:5);
writeln;
end;
for i:=1 to 10 do
for j:=2 to 3 do
s:=s+b[i,j];
write(' Всего сотрудников в учреждении: ',s);
for i:=1 to 10 do
gi:=gi+b[i,2];
write(' Женщин в учреждении: ',gi);
for i:=1 to 10 do
bo:=bo+b[i,3];
write(' Мужчин в учреждении: ',bo);
if (gi>bo) then write(' женщин больше')
else write(' мужчин больше');
if (gi=bo) then write(' женщин и мужчин одинаковое количество');
end.

+ 0 -
Elvira10
02 июля 2014 г., 2:19:29 (9 лет назад)

Возможно, не элемены первой строки, а элементы первого столбца? Ведь судя по объявению массива там столбцов как раз-таки 3

+ 0 -
2002Artem2002
02 июля 2014 г., 3:52:01 (9 лет назад)

Написано в задании "строка"

Ответить

Читайте также

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив. Задание 2.

Заполнить двухмерный массив NM [1..5,1..5] константами:

100 101 102 103 104
200 201 202 203 204
300 301 302 303 304
400 401 402 403 404
500 501 502 503 504

Срочно! Помогите! Написать программу в турбо паскале Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить,

есть ли в нем одинаковые соседние элементы.

Пример:

Исходный массив:

4 0 1 2 0 1 3 1 1 0

Заранее огромное спасибо!!!!

Написать в Паскаль.

Двухмерный массив размером M*N заполнить случайными целыми числами в интервале от -90 до 0. Вывести полученный массив на экран в виде таблицы. Найти количество элементов кратных 4 в последней строке.



Вы находитесь на странице вопроса "Паскаль.двухмерный массив.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.