Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

За решение 4 задач студент получил оценки (от 1 до5) Составьте программу, которая определит среднее значение оценок, полученных студентом за задачи!

5-9 класс

РЕШИТЕ ПЛИЗ В ПАСКАЛЕ!!!!! 8 КЛАСС!!

Brushlusarrb 11 авг. 2013 г., 4:41:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
555dima999
11 авг. 2013 г., 5:19:10 (10 лет назад)

var

i,x:integer;
sr:real;
begin
sr:=0;
for i:=1 to 4 do
begin
write('Оценка за задачу №',i,' ');
readln(x);
sr:=sr+x;
end;
sr:=sr/4;
write('Средняя оценка ',Round(sr));
End.

+ 0 -
Nastia881
11 авг. 2013 г., 6:38:06 (10 лет назад)

5 сек

Ответить

Читайте также

Д/з 6 класс

1. Чему равны значения переменных
r, a, d?

a:=5; b:=20; c:=-7;

d:=2.5;

r :=
a+(4*b+c)*d;

a:= a+4;

d:=a*7;


2. В пяти тестовых опросах мальчик получил оценки. Составьте
программу, которая определит среднее значение оценок, полученных мальчиком в
пяти опросах.




3*. Задача. «Покупка в магазине»

Человек делает в магазине покупки. Определите сколько денег
у него останется после покупки в магазине перчаток стоимостью А руб., портфеля
стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с
клавиатуры.



Исходные данные.

a — стоимость перчаток;

b — стоимость портфеля;

d — стоимость галстука;

dengi — количество денег у человека.

Все эти переменные будут вещественного типа.

Результат.

ostatok — количество денег, которое останется у человек
(вещественный тип).

Метод решения.

ostatok = dengi – a – b – d

Написать программу, реализующую данную задачу





Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

В пяти тестовых опросах мальчик получил оценки. Составьте программу,

которая определит среднее значение оценок, полученных мальчиком в
пяти опросах. Напишите пожалуйста всю задачу,чтобы ничего вставлять не надо было

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.




Вы находитесь на странице вопроса "За решение 4 задач студент получил оценки (от 1 до5) Составьте программу, которая определит среднее значение оценок, полученных студентом за задачи!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.