Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задача F Оплата

10-11 класс

Сегодня Али в местном магазине сделал покупку за С тенге. Он только хотел расплатится и услышал от продавца фразу "Без сдачи пожалуйста, молодой человек" . У него есть N монет достоинства а1, а2, ...., аN тенге. Определите, сможет ли он расплатится без сдачи.
формат входных данных
В первой строке входного файла записаны два целых числа С (1 ≤С ≤ 1000) и
N
(1 ≤ N ≤ 15)- общая сумма покупки и количество монет у Али соотвественно. Во второй строке записаны N целых чисел
а1, а2, ...., аN (1
≤ai ≤ 1000 )-достоинства монет Али.
Формат выходных данных
В единсвенной строке выведите слово "YES", если Али сможнт расплатится без сдачи. Иначе, выведите "NO"

Andreika4 29 янв. 2017 г., 16:16:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bass666
29 янв. 2017 г., 17:56:16 (7 лет назад)

Конечно это самый простой способ. Быть может и не правильно. Var c,n:integer; Begin Readln (n,c); If c=n then writeln ('yes') else writeln (' no'); End.

Ответить

Другие вопросы из категории

в двух байтах представлено целое отрицательное число в формате с фиксированной точкой

1000000100000101
Переведите число в десятичную систему счисления

Здравствуйте, помогите написать програмку в паскале.

-Ввести два трехзначных числа. Если последняя цифра первого числа равна первой цифре второго числа, то утроить каждое число, иначе – найти частное чисел.

Читайте также

Задача F Оплата Сегодня Али в местном магазине сделал покупку за C тенге. Он только хотел расплатится и услышал от прод

авца фразу "Без сдачи пожалуйста, молодой человек". У него есть всего N монет достоинств a1, a2, ..., aN тенге. Определите, сможет ли он расплатится без сдачи.

Формат входных данных

В первой строке входного файла записаны два целых числа C (1 ≤ C ≤ 1000) и N (1 ≤ N ≤ 15) — общая сумма покупки и количство монет у Али соответсвенно. Во второй строке записаны N целых чисел a1, a2, ..., aN (1 ≤ ai ≤ 1000)— достоинства монет Али.

Формат выходных данных

В единственной строке выведите слово «YES», если Али сможет расплатится без сдачи. Иначе, выведите «NO»

Помогите пожалуйста! Составить блок-схему алгоритма решения задачи, условие которой выбирается из списка в соответствии с номером варианта. Оплата за

пользование электроэнергией производится по разным тарифам в зависимости от того, установлены ли в доме электрические или газовые плиты. В первом случае (электрические плиты) стоимость 1 кВт/час составляет 2 руб., во втором – 2.5 руб. Составить программу расчета суммы оплаты за пользование электроэнергией за месяц, если известен расход электроэнергии (количество потребленных в течение месяца кВт/час)

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)



Вы находитесь на странице вопроса "Задача F Оплата", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.