Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Для чего нужно описывать массив в программировании?

10-11 класс

Что включает в себя номер и значение элемента массива?

OLYA110682 15 сент. 2016 г., 8:28:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
48681
15 сент. 2016 г., 9:36:15 (7 лет назад)

Массивы для удобства нужны . Например тебе нужно 5 переменных в программе ты их можешь записать так :
{
int a, b, c , d, e;
a= 48;
b=14;
c=-56;
d=468;
e=4;
}
а выводить их так :
{
cout << d << endl;
cout << a << endl;
}
и так далее.

А с массивом все проще.
{
int mas[48,14 ,56,468,4]
}
и выводиться так:
}
cout << mas[4]/*чисто в скобке- это номер где стоит число в массиве*/ << endl;
cout << mas[2} << endl;
{

Когда чисел 5 , оно не особо проще,но когда их много то массив явно облегчит задачу. Или когда вместо чисел - слова нужны,то вместо слов , пишешь номер слова в массиве.

Ответить

Другие вопросы из категории

Сделать одномерный массив.

В массив A[N] занесены натуральные числа. Найти сумму тех элементов, каторые кратны данному значению К. Элементы массива вводить с клавиатуры.

Составьте программу, которая для числа K (от 1 до 99), введенного вами, напечатает фразу «Мне K лет», где K – введенное число, при этом в нужных случаях

слово «лет» заменяя на «год» или «года». Например, при K=70 «Мне 70 лет», при K=15 «Мне 15 лет», при K=23 «Мне 23 года», при K=31 «Мне 31 год».
что значит until и case в этой задаче

нужно создать программу на языке програмирования паскаль, чтобы вводить сведения о авто ( вводить марку) а программа выдавала сведения о ее хозяине (

программа выдает номер авто и фамилию хозяина)

задача:
Сведения об автомобиле состоят из его марки, номера и фамилии владельца. Дана файл f , содержащий сведения о нескольких автомобилях. Найти фамилии влвдельцев и номера автомобилей по данной марки

Разработать программу для расчёта площади

поверхности и объёма шара известного радиуса.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

для чего нужна видеопамять


Вы находитесь на странице вопроса "Для чего нужно описывать массив в программировании?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.