Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В массиве целых чисел вывести номер и значение 2 максимальных элиментов.Найти их суму.

10-11 класс

Vfhbi 07 мая 2013 г., 17:12:49 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hrenatulka96
07 мая 2013 г., 19:48:42 (11 лет назад)

begin
readln(n, a[1],);
max1:=a[1];
max2:=a[1];
for I:=2 to n do begin
readln(a[i]);
if a[i] > max1 then begin
max1:=a[i];
t:=i;
end;
if a[i]max2 thenbegin
max2:=a[i];
k:=i;
end;
writeln(t,' ',max1);
writeln(k,' ',max2);
s:=max1+max2;
writeln(s)
end.

Ответить

Читайте также

1) найди последний элемент массива меньше заданного числа

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!

Для упорядочивания по возрастанию массива целых чисел из 20 элементов (номера элементов начинаются с 0) начинающий программист написал следующий фрагмент

программы:
For i:=1 to 100 do
For j:=0 to 17 do
If a [j] > a [j+2] then
Begin
T := a [j]; a [j] := a [j+2]; a [j+2] := t
End;
Чему станет равен элемент массива с номером 17, если в начале работы фрагмента в массиве находились числа от 20 до 1 в порядке убывания?

Одномерные массивы. 3 задачки))

1) Из элементов данного массива W[1..20] создать 2 новых массива, первый из которых содержит только положительные элементы, а второй только отрицательные.

2) Заполнить СЛУЧАЙНЫМИ числами в диапазоне от 1 до 10 два массива A[20] и B[20]. Найти и вывести на экран только те элементы этих массивов и их номера, значения которых попарно совпадают.
Например, если A[2]=B[2]=4, то на экран надо вывести: Номер-2, значение-4.
3) Заменить найденный минимальный элемент числом 100 и показать на экране массив с этой заменой.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.



Вы находитесь на странице вопроса "В массиве целых чисел вывести номер и значение 2 максимальных элиментов.Найти их суму.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.