Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить программу , которая будет вычислять факториал заданного числа (вероятно вводится с клавиатуры) через рекурсию в Pascal ABC.

5-9 класс

.

Svetlanaegorov1 11 сент. 2014 г., 14:50:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dgyh
11 сент. 2014 г., 16:46:41 (9 лет назад)

var
 x,i,y:integer;
begin
 Readln(x);
 y:=1;
 for i:=1 to x  do
  y:=y*i;
 writeln(y);
end.
При этом выполняется 0!=1, что справедливо 

Ответить

Другие вопросы из категории

В школе учатся четыре талантливых подростка: Иван, Петр, Алексей и Андрей. Один из них – будущий хоккеист, другой преуспел в футболе, третий – легкоатлет,

четвертый подает надежды как баскетболист. О них известно следующее: Иван и Алексей присутствовали в спортзале, когда там занимался легкоатлет.Петр и хоккеист вместе были на тренировке баскетболиста.Хоккеист раньше дружил с Андреем, а теперь неразлучен с Иваном.Иван не знаком с Алексеем, так как они учатся в разных классах и в разные смены. Кто чем увлекается? футболист баскетболист легкоатлет хоккеист Иван Петр Алексей Андрей

1. Сколько клеток входит в диапазон А2 : B9?

А. 5 В. 8 С. 14 D. 16 Е. 2

Читайте также

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Составить программу , которая будет вычислять факториал заданного числа (вероятно вводится с клавиатуры) через рекурсию в Pascal ABC.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.