Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Как в памяти компьютера представляются целые положительные и отрицательные числа??помогите пож*((

5-9 класс

FreshMen126 01 мая 2015 г., 21:12:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anastasia343
01 мая 2015 г., 22:04:18 (9 лет назад)

проще:
даётся 4 байта или 16бит для целого числа, 1бит отводится на разрядность, если он 0, то число отрицательное, иначе положительное, остальные 15 бит хранят само число

Ответить

Другие вопросы из категории

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.

Читайте также

1) Текст занимает 2 Кбайта памяти компьютера. Сколько символов содержит этот текст?

2) Свободный объём оперативной памяти компьютера 440 Кбайт. Сколько страниц книги поместится в ней, если на странице 16 строк по 64 символа в строке?
3) Десятичный код (номер) буквы "е" в таблице кодировки символов ASCII равен 101. Какая последовательность десятичных кодов будет соответствовать слову help?

Какие задачи решает ПК? Какое устройство необходимо компьютеру для хранения и запоминания информации? Какие виды памяти вы знаете? Что представляет собой

структура памяти ПК? В каком виде ПК хранит в памяти информацию? Что такое байт? Какое максимальное число может храниться в 1 байте? Основные блоки входящие в структурную схему ПК? Какое устройство необходимо для управлением компьютером? Какие устройства ввода информации вы знаете? Какие устройства вывода информации вы знаете? Для чего необходимо …

1) (9класс)Укажите, каков бы был диапазон целых чисел, если бы для их хранения использовалась 4-разрядная ячейка. 2)Запишите внутреннее представление

следующих десятичных чисел, используя 8-разрядную ячейку: а. 32; b. -32; c. 102; d. -102; e. 126; f. -126. 3)Определите, каким десятичным числам соответствуют следующие двоичные коды 8-разрядного представления целых чисел: a. 00010101; b. 11111110; c. 00111111; d. 10101010 4)В чем различие представления в памяти компьютера вещественных чисел с обычной и с удвоенной точностью?

Уточните, каков объем оперативной памяти компьютера (у меня 16 гб),к которому вы имеете доступ дома или в школе .Сколько страниц текста можно разместить в

памяти этого компьютера (на странице размещается 40 строк 60 символов в каждой строке , а для хранения одного символа требуется 8 битов)? Какой была бы высота такой стопки страниц ,если высота стопки из 100 страниц равна 1 см? Объясните пожалуйста как решить.

1.постарайтесь объяснить зачем компьютеру два вида памяти?

Внутренняя и внешняя?

2.что такое принцип хранимой программы?

3.в чем заключается свойство дискретности внутренней памяти компьютера?

4.какие два значения имеет слово бит? как они связанны между собой?

5.в чем заключается свойство адресуемости внутренней памяти компьютера?

6.назовите устройства внешней памяти компьютера?

7.какие типы оптических дисков вы знаете?



Вы находитесь на странице вопроса "Как в памяти компьютера представляются целые положительные и отрицательные числа??помогите пож*((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.