Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить задачу в паскале Задание 2. номер 8

5-9 класс

Ssonnyc 30 сент. 2013 г., 17:30:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Byra1n
30 сент. 2013 г., 19:56:39 (10 лет назад)

var
  hmax, hmin, h: integer;

begin
  hmax := 0;
  hmin := 300;
  writeln('Вводите рост группы людей в см, конец ввода по значению 0');
  repeat
    read(h);
    if h > 0 then
    begin
      if hmax < h then hmax := h;
      if hmin > h then hmin := h
    end
  until h <= 0;
  writeln(#13#10, 'Максимальный рост превышает минимальный на ', hmax - hmin)
end.

Тестовое решение:

Вводите рост группы людей в см, конец ввода по значению 0
165 175 180 175 168 163 176 0

Максимальный рост превышает минимальный на 17



+ 0 -
Ericson1999
30 сент. 2013 г., 20:48:01 (10 лет назад)

var   a,b,h,x,f:real;
begin
write('Введите a,b,h: ');
readln(a,b,h);
x:=a;
writeln('x':8,'F(x)':12);
repeat
  f:=2*tan(x/2)+1;
  writeln(x:10:3,f:10:3);
  x:=x+h;
  until x>b;
end.

Ответить

Другие вопросы из категории

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!

Составить программу на паскале вводящую имя в 1 строке и в каком классе во 2 строке

(вместо имени и фамилии напишите что-нибудь левое, например "имя" "фамилия", класс там например "1Н', я потом изменю как мне надо будет). Писать это в тетради

Читайте также

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

пожалуйста, помогите решить задачи по Паскалю!!!

1) Даны два числа. Составить алгоритм и перевести его на язык программирования, который меньшее из них возводит в квадрат, а большее оставляет без изменения,

ПОМОГИТЕЕ


Помогите решить задачи на паскаль.

1)
Дан массив случайных чисел (количество элементов
вводите с клавиатуры). Найти произведение всех элементов массива.



Вы находитесь на странице вопроса "Помогите решить задачу в паскале Задание 2. номер 8", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.