Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

НАПИСАТЬ ПРОГРАММУ.

5-9 класс

Угадай число. Один из партнеров вводит в программу число, а второй должен отгадать это число. Причем на каждый предложенный вариант программа отвечает либо «больше», либо «меньше» до тех пор, пока число не будет отгадано. Вывести количество попыток, которое было сделано.

Volvo34rus 21 апр. 2015 г., 8:20:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Phillip123
21 апр. 2015 г., 10:25:34 (9 лет назад)

var a,i,b:integer;
begin
  writeln('Введи число');
  readln(a);
  writeln('Уадай');
  while a<>b do
  begin
  readln(b);
  if a<b then 
  begin writeln('Меньше'); i:=i+1; end
  else
  if a>b then
  begin writeln('Больше'); i:=i+1; end;
  end;
  writeln('Попыток было:', i)
end.

Ответить

Другие вопросы из категории

1,Во сколько раз в позиционных системах счисления различаются цифры соседних разрядов числа?

2.Может ли в качестве цифры в системе счисления использоваться символ буквы?

Читайте также

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, как

соотносятся между собой два произвольных числа A и B.

2. Фирма осуществляет набор сотрудников. Условия приема требуют не менее 3 лет рабочего стажа и возраст не более 35 лет. Написать программу, проверяющую, удовлетворяет ли кандидат этим требованиям.



Вы находитесь на странице вопроса "НАПИСАТЬ ПРОГРАММУ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.