Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

даны три квадратных уравнения. сколько из них имеют вещественные корни

5-9 класс

1 уравнение ax^2+bx+c=0
2 уравнение bx^2+ax+c=0
3 уравнение cx^2+ax+b=0
объясните пожалуйста

Sanamwox 11 мая 2013 г., 21:52:06 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olga2708
12 мая 2013 г., 0:37:06 (11 лет назад)

var
    a, b, c: real;
    k := 0;

begin
    readln(a, b, c);
    k := k + integer(b * b - 4 * a * c >= 0);
    k := k + integer(a * a - 4 * b * c >= 0);
    k := k + integer(a * a - 4 * c * b >= 0);
    writeln(k);
end.

+ 0 -
Like36
12 мая 2013 г., 1:38:21 (11 лет назад)

это программу надо написать? где мы берем значенья переменных a,b,c ?

+ 0 -
F0kYsss
12 мая 2013 г., 2:32:47 (11 лет назад)

автар "мы должны сами ввести a,b,c,любые числа"

Ответить

Читайте также

Задача на круги Эйлера. В классе 40 человек. Из них по русскому языку имеют "3" 19 человек, по математике 17 человек и по физике 22 человека. Только

по одному предмету имеют "3" : по русскому языку 4 человека, по математике 4 человека и по физике 11 человек. Семь человек имеют "3" и по математике и по физике, из них пятеро имеют "3" и по русскому языку. Сколько человек учатся без "3" ? Сколько человек имеют "3" по двум из трёх предметов?

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни



Вы находитесь на странице вопроса "даны три квадратных уравнения. сколько из них имеют вещественные корни", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.