Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача в Pascal!!!!!!

5-9 класс

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).

Выходные данные:
Вывести единственное число.

Пример входного файла (input.txt):
10 1 1 2 3

Tinazhurova1 22 сент. 2013 г., 13:49:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Елена123459
22 сент. 2013 г., 15:19:45 (10 лет назад)

var
  A, B, C, D, N, V, K, M: integer;
  F: Text;

begin
  Assign(f,'input.txt');
  Reset(f);
  Readln(N,A,B,C,D);
  Close(f);
  V := A * B * N;
  if V mod C <> 0 then
    K := V div C + 1
  else
    K := V div C;
  if K mod D <> 0 then
    M := K div D + 1
  else
    M := K div D;
  writeln(M)
end.

Тестовое решение:

2

Ответить

Другие вопросы из категории

Пожалуйста, помогите составить линейный алгоритм

на тему:
создание списка с курсивным начертанием цифр.
Очень срочно!!!

На берегу реки стоит крестьянин с лодкой, а рядом с ним-волк, коза и капуста. Крестьянин должен переправиться сам и перевезти волка, козу и капусту на

другой берег. Однако в лодку кроме крестьянина помещается либо волк, либо только коза, либо только капуста. Оставлять волка с козой либо козу с капустой без присмотра нельзя- волк может съесть козу,- а коза капусту. Как должен поступить крестьянин?

Читайте также

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

Решить задачу в Pascal ABC

Даны два целых числа. Разделить каждое число на целое число d.
Найти произведение их остатков от деления.

Помогите пожалуйста решить задачу в pascal ABC. Очень срочно нужно

Составьте программу, позволяющую определить, будет ли введённая строка перевёртышем после удаления из неё всех пробелов

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC



Вы находитесь на странице вопроса "Задача в Pascal!!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.