Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

НАЙТИ СУММУ ЦИФР ЗАДАННОГО ЧИСЛА 3456,ЗАДАНО 4-Х ЗНАЧНОЕ ЧИСЛО,НАЙТИ,ЕСТЬ ЛИ СРЕДИ НИХ ЦИФРА 7?

10-11 класс

Katuruna50 12 нояб. 2016 г., 17:37:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Laziko79
12 нояб. 2016 г., 18:53:45 (7 лет назад)

var a,b:integer;

is7:boolean;

begin

   readln(a);

   b:=0;

   is7:=false;

   while a <>0 do

   begin

       b:=b+a mod 10;

       if a mod 10 = 7 then

            is7:=true;

        a:=a div 10;

   end;

   wrtieln('Сумма цифр: ', b);

   write('Цифра 7 ');

   if is7 then writeln('есть') else writeln('нет');

   readln;

end.

+ 0 -
Vkosovskyy
12 нояб. 2016 г., 20:01:39 (7 лет назад)

сумма=18

семерки нету

или тебе программу написать?

 

 

Ответить

Другие вопросы из категории

Молодой стажер технического отдела Васечкин получил свое первое самостоятельное задание: установить на новый компьютер директора драйвера от

периферийных устройств. Отправляясь на свое задание, Васечкин получил от своих более опытных коллег по работе напутствие, в каком порядке нужно устанавливать драйвера. Но коллеги были с чувством юмора и решили дать советы, в которых лишь половина является правдой, а остальное сознательной ложью.

Помощник мастера: Первым можно установить только сканер, а внешний жесткий диск – предпоследним.

Диспетчер: Монитор устанавливай обязательно вторым, а четвертым – внешний жесткий диск.

Начальник отдела: Монитор необходимо устанавливать вторым, а сканер только третьим.

Старший мастер: Никогда не ставь третьим принтер, не нужно ставить последней музыкальную клавиатуру.

Младший мастер: Музыкальную клавиатуру можно поставить самой первой, а вторым – принтер.

Помогите Васечкину восстановить точную последовательность установки драйверов. В ответе укажите подряд первые буквы устройств в том порядке, в котором необходимо устанавливать для них драйвера.

( В – внешний жесткий диск, К – музыкальная клавиатура, М – монитор, П – принтер, С – сканер).

помогите 12-13 задание
Сколько

решений имеет уравнение (АВ)↔(АС) = А(А→С), где А, В, С – логические переменные?

Читайте также

1. Составьте алгоритм вычисления суммы квадратов цифр,заданного трехзначного числа.

2.Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.
3. Для заданного действительного числа К вычислить значение произведения
(99/k^3-98)*(97/k^3+96)*(95/k^3-94)*...*(3/k^3+2)

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух

последних цифр заданного числа; 3) число, образованное перестановкой второй и четвёртой цифр заданного числа.

1.определить,есть ли среди цифр заданного трехзначного числа одинаковые.

2.вычислить стоимость покупки с учетом скидки.Скидка в 10% предоставляется,если сумма покупки больше 1000 руб.



Вы находитесь на странице вопроса "НАЙТИ СУММУ ЦИФР ЗАДАННОГО ЧИСЛА 3456,ЗАДАНО 4-Х ЗНАЧНОЕ ЧИСЛО,НАЙТИ,ЕСТЬ ЛИ СРЕДИ НИХ ЦИФРА 7?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.