Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

решите пожалуйста в Турбо Паскаль

5-9 класс

Andrejvelichko1234 20 февр. 2015 г., 21:44:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yuki666
20 февр. 2015 г., 23:56:52 (9 лет назад)

program task1;
var  Digit, i, sum, err :integer;  Digit_str :string;
begin
  readln(Digit);    str(Digit,Digit_str);  sum:= 0;  for i:= 1 to length(Digit_str) do  begin    val(Digit_str[i],Digit,err);    sum:= sum + Digit;  end;  if sum mod 2 = 0 then    writeln('Верно')  else    writeln('Не верно');  end.

program task2;
var  Digit, i, err :integer;  Digit_str :string;  two, five :boolean;
begin
  readln(Digit);    str(Digit,Digit_str);  two:= false; five:= false;  for i:= 1 to length(Digit_str) do  begin    val(Digit_str[i],Digit,err);    if Digit = 2 then      two:= true;    if Digit = 5 then      five:= true;  end;  if (two = true) and (five = true) then    writeln('есть')  else    writeln('нет');   end.

program task3;
var  Digit, i, sum, err :integer;  Digit_str :string;
begin
  readln(Digit);    str(Digit,Digit_str);  sum:= 0;  for i:= 1 to length(Digit_str) do  begin    val(Digit_str[i],Digit,err);    sum:= sum + sqr(Digit);  end;  writeln(sum);  end.

Ответить

Другие вопросы из категории

В шахматном турнире принимали участие шесть игроков из разных городов России : Иркутска , Воркуты , Саратова , Тюмени , Уфы , и Рязани .В первом

турнире Александр играл с представителем Воркуты , уфимец с Николаем .
Во втором туре Денис играл с представителем Тюмени , а шахматист из Воркуты с Николаем . В третьем туре Михаил играл с иркутянином .
Кто из игроков представлял какой город , если в итоге Николай занял первое место , Геннадий и иркутянин поделили 2 и 3 места , Денис был четвёртым , а Семён и саратовец поделили 5 и 6 места ?
Ребята помогите пожалуйстаааа !!!!

Как на Паскале сравнить два числа N,M<=10^10000;

Вход:N,M<=10^10000;
Выход:Наибольшее число;

Читайте также

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.

РЕШИТЬ ЗАДАЧУ НА ТУРБО ПАСКАЛЕ

ЖЕЛАТЕЛЬНО С ИСПОЛЬЗОВАНИЕМ СТРУКТУРЫ CASE OF

Пусть элементом круга является радиус(первый элемент),диаметр (второй элемент) и длина окружности( третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!



Вы находитесь на странице вопроса "решите пожалуйста в Турбо Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.