Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составьте программу, которая формирует массив из 10 случайных целых чисел в диапазоне от 1 до 20 и выводит на экран элементы, значения которых больше 5,

5-9 класс

но меньше 15.
Это паскаль.

Ksuha97 28 марта 2017 г., 10:29:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
настя11анашкина
28 марта 2017 г., 12:03:17 (7 лет назад)

var a,i:integer;
m:array[1..10] of integer;

begin

a:=10;

randomize;

for i:=1 to a do
begin
m[i]:=random(21);
end;

for i:=1 to a do
if (m[i]>5) and (m[i]<15) then
writeln(m[i]);
end. 

Ответить

Другие вопросы из категории

Какой раздел ленты отвечает за форматирование шрифта?

А.Главная
В.Вставка
С.Размер страницы
Д.Черновик

Что такое кегль?
А. Вид шрифта
В.Размер шрифта
С.Цвет шрифта
Д.Стиль шрифта

Что такое гарнитура
А.Вид шрифта
В.Размер шрифта
С.Цвет шрифта
Д.Стиль шрифта

Читайте также

Помогите пожалуйста)

1.Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов с четными значениями и четными индексами.
Пример ввода:4 5 6 3 9 8 4 10 7 2
2.Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы,значения которых больше 5 и меньше 15.

1)Составьте программу, которая заполняет массив a [1...10] случайными целыми числами в диапазоне от 1 до 20 и вывода на экран элементов массива с

нечётными значениями.
2) Соединить :D
1- двоичный код
2- кодирование
3- система счисления
4- основание
5- разряд
а- Процесс преобразования информации из одной форму представления в другую
б- Набор из нулей и едениц
в- Позиция цифры в числе
г- Способ запичи чисел
д- Число цифр, которые используются в системе счисления для записи чисел

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно



Вы находитесь на странице вопроса "Составьте программу, которая формирует массив из 10 случайных целых чисел в диапазоне от 1 до 20 и выводит на экран элементы, значения которых больше 5,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.