Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

есть число какую нужно написать программу чтобы куб цифр этого числа в сумму давал это число к примеру число 153 1*1*1+5*5*5+3*3*3 ЭТО НУЖНО ЗАПИСАТЬ

5-9 класс

НА ЯЗЫКЕ ПРОГРАМИРОВАНИЯ PASKAL ABC

Zamzamgul92 03 февр. 2017 г., 4:38:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pika12
03 февр. 2017 г., 6:00:24 (7 лет назад)

uses crt;

 

var

  n, r, k : Integer;

begin

  clrscr;  

  r := 0;

 

  Write('Введите число:');
  ReadLn(n);

 

  k := n mod 10;
  r := r + k*k*k;

 

  k := n div 10 mod 10;
  r := r + k*k*k;

 

  k := n div 100;
  r := r + k*k*k;

 

  Writeln(r);
  Readln;
end.

+ 0 -
VikaIlina
03 февр. 2017 г., 7:21:44 (7 лет назад)

Program Chelovekkk;
{работает для чисел любой длины, не только для 3-значных}

uses crt;
var
  n,nt: integer;
  temp, kub : real;
begin
  kub := 0;
  write('Введите число ');
  readln(n);
  nt:=n;
  writeln('*** alphaues is thinking... ***');
  while nt>=1 do
    begin
    temp:=nt mod 10;
    kub := kub + temp*temp*temp;
    nt := nt div 10;
  end;
  writeln('Сумма кубов цифр числа ',n,' равна ',kub);
end.

Ответить

Другие вопросы из категории

информатика

третье
решите плиз

Решите пожалуйста!!!

Переведите следующее число в двоичную систему счисления:
Расписать всё по действиям!!!

Напишите пожалуйста программу на Turbo pascal :

Найти частное двух целых чисел вводимых с клавиатуры

помогите решить задачу:

даны 3 имя,Джули,Линла и Айрис.
даны 3 города,Париж ,РИМ,Чикаго,
3 прафессии: кино,балет и пение,
1.Джели живет не в Париже,а Линда не в Риме.
2. парижанка не снимается в кин
3.линда равнодушна к балету.
где живет Айрис и какова ее профессия?

Маша птичкина любит играть в игру веселый фермер. И вот как-то раз ее ферма нуждалась в покраске . Маша решила начать с противопожарного щита и

покрасить его почему-ир не в красный а в оранжевый цвет. Но для этого надо смешать краски желтого(6 частей) и красного (2 части) цветов. Сколько грамм оранжевой краски может получить маша имея в наличии 300 г. Желтой и 600 г. Красной краски а) 300 б) 400 в) 600 г) 900

Читайте также

нужно написать программу (packal abc). программа такая: введи три числа (неизвесно какие 3 числа (целые или вещественные) так что 6 чисел ну типа

такого: var a,b,c:(integer)-целые; l,k,n:(real)-вещественные), найти сумму первых двух чисел, частное второго и третьего числа и утроить сумму трёх чисел. мне нужно составить программу дальше я знаю только начало: program ur1; var a,b,c:integer; l,k,n:real; begin и всё я дальше не могу сделать, помогите полажуйста чем можете!



Вы находитесь на странице вопроса "есть число какую нужно написать программу чтобы куб цифр этого числа в сумму давал это число к примеру число 153 1*1*1+5*5*5+3*3*3 ЭТО НУЖНО ЗАПИСАТЬ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.