Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить приложение на языке Pascal.Определить в какую четверть координатной плоскости

10-11 класс

попала точка с координатами (x,y). Переменной N
присвоить номер четверти. Если точка попала в начало
координат, то N=0. Если точка попала на ось X или Y, то
напечатать сообщение об этом.

Aa11111 01 июня 2014 г., 10:27:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Al30
01 июня 2014 г., 12:31:56 (9 лет назад)

 

 

uses crt;

var x,y:real;

n:integer;

begin

clrscr;

writeln('Введите координаты точки:');

readln(x,y);

if(x=0)and(y<>0) then write('Точка попала на ось Y')

else if (x<>0)and(y=0) then write('Точка попала на ось Х')

else

begin

 else if (x>0)and(y>0)then n:=1

 else if (x<0)and(y>0) then n:=2  

 else if (x<0)and(y<0) then n:=3   

 else if(x>0)and(y<0) then n:=4

 write('n=',n);  

 end; 

 readln end.


Ответить

Другие вопросы из категории

Дано

число k (0 < k < 11) и матрица размера 4 x 10. Найти сумму и произведение
элементов k-го столбца данной матрицы.

восстановии цепочку чисел 42 45 49 ...94
Помогите пожалуйста решить задачу в Excel.

В небольшом предприятии его сотрудникам выдаётся месячная зарплата. Кассир, имея на руках бухгалтерскую ведомость, собирается ехать в банк за деньгами. При этом он имеет возможность не просто подать заявку на общую сумму, а указать в ней также, какими именно купюрами ему хотелось бы получить её. Делается это для того, чтобы потом было удобнее рассчитываться с каждым отдельным работником (например, если выплаты производится, как говорят, «в конвертах»). Предварительно все исходные данные нужно представить в виде таблицы, где против каждой фамилии сотрудника, как только вводится начисленная ему зарплата, она тут же выражается соответствующим набором денежных знаков. Одновременно подводится и общий итог по всему коллективу для формирования банковского заказа. При определении набора следовать принципу наименьшего числа купюрРади упрощения задачи расчёт вести только на бумажные деньги с точностью до 10 рублей
Для расчётов использовать встроенные функции ЦЕЛОЕ и ОСТАТ из категории «математических» .

Задача

Сколько килобайт
будет занимать файл в простом текстовом формате, если в тексте 300 страниц, на
странице 25 строк, а в строке в среднем 45 символов?



Задача




В
каталоге находится 6 файлов:

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Составить приложение на языке Pascal.

С помощью ПК произвести обработку одномерного массива, заданного
в таблице. Элементы одномерного массива задать числами в диапазоне
– 20 . . . +50. Необходимо:

описать массив

ввести элементы массива из заданного диапазона;

выполнить с элементами массива действия

вывести результаты на экран.

Составить приложение на языке Pascal. Вычислить на ПК значения функции, заданной в таблице. На печать

вывести значения вводимых исходных данных и полученные результаты,
сопровождая их именами переменных. Значения аргумента взять из
указанного диапазона так, чтобы протестировать все ветви программы.

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Помогите составить программу на языке PASCAL

В матрице X(5×5) определите произведение положительных элементов
главной диагонали.



Вы находитесь на странице вопроса "Составить приложение на языке Pascal.Определить в какую четверть координатной плоскости", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.