Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Program primer_2;

10-11 класс

var x,y,z,s:real;
begin
writeln ('Введите значение x');
write('x='); readln(x);
s:=ln(abs(y))+ abs(ln(z));
if x<-2 then y:=2*x;
if -2<=x<=2 then y:=sin(x*e-3)+ln(abs(x));
if x>2 then y:=power((power(cos(sqr(x)),2)+ power(sin(power(x,3)),4)),4);
if x<0 then z:=power(sin(x),2);
if x>=0 then z:=power(e,-(sqr(x+3)));
writeln('Ответ');
writeln('s=',z:8:3);
end.
Ошибка в (if -2<=x<=2 then y:=sin(x*e-3)+ln(abs(x));) пишет что "Операция '<=' не применима к типам integer и boolean"
Кто сможет исправить?



0ля 21 янв. 2015 г., 7:26:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MVlada
21 янв. 2015 г., 8:30:30 (9 лет назад)

в паскале нельзя сравнивать более 2-ух чисел за раз в типе данных интеджер
и строчка 
"if -2<=x<=2 then y:=sin(x*e-3)+ln(abs(x));"

Ответить

Другие вопросы из категории

Написать программу по ПРОЦЕДУРАМ с массивами в языке программирования Pascal.

Задание:
Дан массив целых чисел. Найти сумму положительных нечетных. Обязательно по процедурам с массивами

напишите ответ

определить площадь стен помещения 4,если высота помещения -3 метра

Читайте также

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

Какая тут ошибка, посмотрите, пожалуйста program znacheniya uglov; uses crt; var x: integer; begin writeln('wedite znachenie gradusnoi mery ugla');

read(x); if a=180 then writeln('razvernutyi') else writeln ('ne razvernutyi'); end.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

program vst; var

c:



Вы находитесь на странице вопроса "Program primer_2;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.