Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Для числа N определите, сколько нулей в конце десятичной записи N - Факториал

10-11 класс

Nastytretyakova 18 дек. 2013 г., 23:53:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Favn666unicorn
19 дек. 2013 г., 0:56:07 (10 лет назад)

var n,k2,k5,i,a:integer; begin write('n='); read(n); k2:=0; k5:=0; for i:=2 to n do  begin   a:=i;   if a mod 2=0 then   while a>=2 do    begin     a:=a div 2;     k2:=k2+1;    end;   a:=i;   if a mod 5=0 then   while a>=5 do    begin     a:=a div 5;     k5:=k5+1;    end;  end; if k2<k5 then write(k2) else write(k5); readln end.

Ответить

Другие вопросы из категории

внешний жесткий диск(D)объём1Тb стоит 4000 рублей,USB-флэш-накопитель(F)на 32 GD стоимость 1000 рублей,CD-R (C) объёмом 700 Mb стоит 14 рублей.

Расположить эти носители по возрастанию стоимость за 1 байт.А)D F C Б)D C F В) F D C Г)F C D

Читайте также

N-Factorial это произведение всех чисел от 1 до N. Для задного числа N определите сколько нулей в конце десятичной записи N-Factorial .

В единственной строке входного файла содержится одно целое положительное числа NN(1

Задача А Четные

N-Factorial - это произведение всех чисел от 1 до N.Для заданного числа N определите,сколько нулей в конце десятичной записи.
Формат входных данных

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

1. Определить, сколько байт содержится в 0.125 Гбайтах. Результат представить как возведенное в степень число 2.

2. Определить, сколько Гбайт содержится в 512 байтах. Результат представить как возведенное в степень число 2.



Вы находитесь на странице вопроса "Для числа N определите, сколько нулей в конце десятичной записи N - Факториал", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.