Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Создайте массив значений результатов забега на 100метров группы мальчиков из 18 человек.Определите средний результат забега и кол-во

5-9 класс

человек,показавших время ниже среднего значения.Сколько человек показали средний результат?Определите победителя забега и аутсайдера,каков разрыв времени между ними.Выведите результаты,соответствующие первым трем местам результаты...ПОМОГИТЕ ПЛИИИЗ ОЧЕНЬ НАДО РЕШАЕТСЯ ОЦЕНКА

Liyapak2003 08 янв. 2017 г., 20:56:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Clubkiller20
08 янв. 2017 г., 23:47:31 (7 лет назад)

var 

   a: array[1..18] of integer;

   n,i,sr,k1,k2,imin,min,imax,max,p2,p3: integer;

begin

n:=18;

max:=32000; min:=-1; sr:=0;

for i:=1 to n do

begin

read(a[i]);

sr:=sr+a[i];

if a[i]>max then begin max:=a[i]; imax:=i; end;

if a[i]<min then begin min:=a[i]; imin:=i; end;

end;

sr:=sr div n;

writeln('Среднее значение: ',sr);

k1:=0; k2:=0;

for i:=1 to n do

 if a[i]<sr then k1:=k1+1 else 

     if a[i]=sr then k2:=k2+1;

writeln('Быстрее среднего результата пробежали ',k1,' человек');

writeln('Cо средним результатом пробежали ',k2,' человек');

writeln('Победил ',imin,'ый спортсмен, прибежав за ', min,' секунд');

writeln('Аутсайдер - ',imax,'ый спортсмен, прибежавший за ', max,' секунд');

writeln('Разрыв между первым и последним = ',max-min);

min:=0;

for i:=1 to n do

 if (i<>imin) and (a[i]<min) then begin min:=a[i]; p2:=i; end; 

writeln('Вторым прибежал ',p2,'ый спортсмен');

min:=0;

for i:=1 to n do

 if (i<>imin) and (i<>p2) and (a[i]<min) then begin min:=a[i]; p3:=i; end; 

writeln('Третьим прибежал ',p3,'ый спортсмен');

readln; 

end.

Ответить

Другие вопросы из категории

Вот шифр цезаря на паскале но в чем заключаеться вопрос, в том что если в слове есть буква близкая к концу алфавита например я то прибавляя ключ (например

3) он не может перескочить к началу алфавита! помогите пожалуйста!
program z1;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование? 1-да, 0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:='';
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do
for j:=1 to length(b) do
begin
If g=0 then k:=(j-d) mod 32 else k:=(j+d);
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.

Помогите решить пожалуйста(подробно): Найдите ошибки в алгоритме: for i:= 1 to n do

begin
for j:= 1 to m do
c[i,j]:=a[i,j]+ a[i,j]
end;

Какую типовую задачу выполняет алгоритм?

Читайте также

помогите пожалуйста )

1. Любой носитель , изначально имеющий один каталог ,который создается операционной системой без участия пользователя , называется :1) Главным 2) Основным 3) Корневым 4) Первым
2. К системному программу обеспечению не относятся :1) Драйверы 2) Антивирусные программы 3) Коммуникационные программы 4) Система программирования
3. На уроке в результате математических действий группа детей из четырех человек получила разные ответы. Миша сказал " Это число 10" , Саша:" Это простое число " . Кристина :" Это нечетное число", а Маша :" У меня получилось 12" . Какое это число , если и девочки и мальчики ошиблись ровно по одному разу? 1) 10 2)12 3)3 4)1
4. Определите количество различных решений в уравнении (А ^ Б ) v (С ^ Г )=1 1) 1 2) 5 3) 7 4 ) 8
5. Десятичное число 25 в некоторой системе счисления записывается как 121 . Найдите основание этой системы счисления . 1) 2 2)3 3)4 4) 5

На уроке в результате математических действий группа детей из четырех человек получила разные ответы. Миша сказал "это число 10", Саша: "Это простое

число". Кристина: "Это нечетное число", а Маша: "У меня получилось 12". Какое это число, если и девочки и мальчики ошблись ровно по одному разу?

на уроке в результате математических действий группа детей из четырех человек получает разные ответы. Миша сказал "это число 10", Саша:"это простое

число". Кристина: "это нечетное число", а Маша: "у меня получилось 12".Какое это число, если и девочки и мальчики ошиблись ровно по одному разу?

а)10 б)12 в)3 г)1

Задали очень сложну ззадачу по паскалю!!

Составим программу "КАЛЬКУЛЯТОР", которая после ввода двух чисел и одного из знаков +, -, *, / произведёт вычисления, а результат выдаст на экран.


Составить программу которая определяет средний балл учащихся группы.

Программа должна спрашивать:
₋ сколько в группе человек,
₋ какой средний балл у каждого учащегося.
Пожалуйста составьте правильно, очень надо, заранее спасибо.



Вы находитесь на странице вопроса "Создайте массив значений результатов забега на 100метров группы мальчиков из 18 человек.Определите средний результат забега и кол-во", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.