Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя. напечатать все совершенные

5-9 класс

числа, меньшие заданного числа N. ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПРОГРАММУ!!!

NiKoLa07 30 окт. 2014 г., 3:09:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлия1000
30 окт. 2014 г., 6:09:01 (9 лет назад)

#include <iostream>
#include <clocale>
#include <cmath>
using namespace std;

void main()
{
setlocale(LC_CTYPE,"rus");
int x, sum=0;
cout<<"Введите переменную: ";
cin>>x;
for(int i=1; i<x;i++)
{
if(x%i==0)
sum+=i;
}
if(x==sum)
{cout<<"Это совершенное число"<<endl;}
else
{cout<<"Это несовершенное число"<<endl;}
}

Ответить

Другие вопросы из категории

оператор WRITE на языке Pascal означает:

1.ввод с клавиатуры значение переменой
2.вывод на экран информации
3.присваивание переменной значения

Читайте также

привет,помогите пожалуйста решить еще задачки))))

1)дано натуральное число N>1.найти количество его делителей
2)дано натуральное число N>1.равно ли оно сумме своих делителей(включая единицу,но не себя)
3)даны числа a и n.вычислить:1/a 1/a*a 1/a*a*a ... 1/a*n
это все цикл for,зарание спасибо!

Автоморфные числа. Натуральное число называется автоморфным, если оно равно последним цифрам его квадрата. Например: 25^2=625. Напишите программу, которая

вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Информатика "Программирование разветвляющихся алгоритмов" 1. Увеличить число X на 10, если оно положительное,

во всех остальных случаях уменьшить на 10.

2. Увеличить число X на 5, если оно положительное.

Назовем натуральное число сверхнечетным, если оно состоит только из нечетных цифр. Требуется для заданного значения n найти n-е по счету сверхнечетное ч

исло. Вход: файл input.txt, содержащий только натуральное число n. Ограничения: 1 ≤ n ≤ 1000000. Выход: файл output.txt, содержащий одно натуральное число – n-е по счету сверхнечетное число. Пример: input.txt output.txt 13 35



Вы находитесь на странице вопроса "натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя. напечатать все совершенные", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.