Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста! Умоляю! дана матрица допустим 4 на 5 надо найти сумму всех элементов Главной диагонали ! потом над главное диагналью и под главной

5-9 класс

диагнали! НА С++ ! Пожалуйста тока там через printf scanf!

Horiton14 07 нояб. 2016 г., 14:27:51 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
0501949152
07 нояб. 2016 г., 15:07:21 (7 лет назад)

#include "stdafx.h"
#include <iostream>

using namespace System;

int main()
{

int m[4][5]={1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19};
int n;
int sum1=0,sum2=0,sum3=0;

for(int i=0;i<4;i++)
for(int j=0;j<5;j++){
if(i==j) sum1+=m[i][j];
else if (j<i)sum2+=m[i][j];
else sum3+=m[i][j];

}

printf("%d %d %d",sum1,sum2,sum3);
return 0;
}

Ответить

Другие вопросы из категории

Помогите! Нужно составить программу на языке паскаль!

Заранее спасибо

Метеорологическая станция ведет наблюдение за влажностью воздуха.

Результатом одного измерения является целое число от 0 до 100 процентов, которое записывается при помощи минимально возможного количества бит. Станция сделала 80 измерений. Определите информационный объем результатов наблюдений.

Петя и Коля играют в следующую игру: Петя задумывает правило преобразования текстовой информации. Коля может предлагать любые тексты и узнавать

результаты преобразования. Ниже приведены вопросы Коли и ответы Пети в нескольких таких играх. Попробуйте отгадать, какое правило задумал Петя в каждой игре.

а-1; мама-4;весна-5

а-1; шея-2; мама-2; огурец-3

а-0; шея-1; мама-2; огурец-3;

а-а; шея-яеш; мама-амам;

а-1; весна-3; дом-5; река-18

прим: -(стрелка)

1.Какое количество информации несет сообщение о том, что встреча назначена на 15-е число. В месяце 30 дней.

2. Сообщение записано буквами, 64 символов в алфавите, содержит 20 символов. Какой объем информации несет.

Читайте также

Помогите,пожалуйста! очень надо!!!!

1. Заполнить двумерный массив размером ( 5, 11 ) целыми числами. Найти сумму положения элементов массива по главной диагонали. Вывести матрицу на экран.

2. Заполнить одномерный массив значением функции у=2 кв. корень из модуль х-2. Х=1,3,5...21. Вывести массив на экран в одну сторону. Найти сумму элементов массива.

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Помогите, пожалуйста, решитьПомогите, пожалуйста, решить задачу!

Вычислить сумму всех элементов двумерного массива. Напишите, пожалуйста, программу.

Дано натуральное число n.Найти сумму всех нечетных чисел от 1 до n

ПОМОГИТЕ ПОЖАЛУЙСТА! У МЕНЯ КОНТРОЛЬНАЯ!! ЗАРАНЕЕ БЛАГОДАРЮ!!)



Вы находитесь на странице вопроса "Помогите пожалуйста! Умоляю! дана матрица допустим 4 на 5 надо найти сумму всех элементов Главной диагонали ! потом над главное диагналью и под главной", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.