Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дано натуральное число n.Найти сумму всех нечетных чисел от 1 до n

5-9 класс

ПОМОГИТЕ ПОЖАЛУЙСТА! У МЕНЯ КОНТРОЛЬНАЯ!! ЗАРАНЕЕ БЛАГОДАРЮ!!)

Spaidy 06 апр. 2014 г., 18:55:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shimar145
06 апр. 2014 г., 21:20:04 (10 лет назад)

Program chisla;

Uses Crt;

var i,n,s:longint;

begin

   clrscr;

    write('Введите n:');

    readln(n); 

    s:=0; 

    for i:=1 to n do 

 

       if (i mod 2)<>0 then s:=s+i;   

 

   writeln('Сумма всех нчётных чисел от 1 до n равна:',s) 

   readkey;

 

end. 

 

 

 

 

 

 

Ответить

Другие вопросы из категории

Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.

Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

For4. Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет. For7. Даны два целых числа A и

B (A < B). Найти сумму всех целых чисел от A до B включительно.

Помогите составить программу решения задачи в паскаль АВС.

Даны два целых числа А и В (А меньше В). Найти сумму всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "Дано натуральное число n.Найти сумму всех нечетных чисел от 1 до n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.