Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Опишите на языке программирования (паскаль) целочисленный массив из 30 элементов и найдите сумму элементов массива.

5-9 класс

Aset2 03 апр. 2014 г., 7:54:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
In262
03 апр. 2014 г., 8:37:20 (10 лет назад)

var

  i, summ : Integer;

  m : array [1..30] of Integer;

begin

  summ := 0;

 

  for i:= 1 to 30 do

  begin

    Write('m[', i, ']=');

    Readln(m[i]);

  end;

 

  for i:= 1 to 30 do

    summ := summ + m[i];

 

  Writeln(Summ);

end.

+ 0 -
Larc
03 апр. 2014 г., 11:02:16 (10 лет назад)

const

  n = 30;

var

  a:array[1..n] of integer;

  i, summ:integer;

begin

  randomize;

  summ := 0;

  writeln('Исходный массив:');

  for i := 1 to n do

  begin

    a[i] := random(21) - 10;

    write(a[i], ' ');

    summ := summ + a[i];

  end;

  writeln;

  writeln('Сумма элементов массива равна ', summ);

end.

Ответить

Другие вопросы из категории

Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.

Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

Читайте также

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 ­– рост учащихся выпускного класса. В баскетбольную команду бе

рут тех, чей рост не менее 180 см. Опишите на русском языке или на одном из языков программирования алгоритм, который подсчитывает и выводит минимальный рост игрока баскетбольной команды. Гарантируется, что хотя бы один ученик играет в баскетбольной команде.Нужно паскаль

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100 – баллы учащихся выпускного класса за итоговый

тест по информатике. Для получения положительной оценки за тест требовалось набрать не менее 20 баллов. Опишите на паскале алгоритм, который позволяет найти и вывести минимальный балл среди учащихся, получивших за тест положительную оценку.

Дан целочисленный

двумерный массив 6x10. Опишите на
русском языке и на языке программирования Паскаль алгоритм вычисления
произведения минимальных элементов из каждой строки. Напечатать значение этого произведения.
Предполагается, что в каждой строке минимальный элемент единственный.

1) Дан

целочисленный массив из 30 элементов. Элементы массива могут принимать значения
от

0 до 1000. Опишите на русском языке или на одном из языков программирования
алгоритм, который находит и выводит среднее арифметическое всех элементов
массива, имеющих нечётное значение. Гарантируется, что хотя бы один такое
элемент в массиве есть.



Вы находитесь на странице вопроса "Опишите на языке программирования (паскаль) целочисленный массив из 30 элементов и найдите сумму элементов массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.