Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

задача в паскале абс

5-9 класс

{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм. прогрессии и n - число членов прогрессии вывести на экран n первых членов прогрессии например a=4
d=2
n=5
4 6 8 10 12 14}

данёк200123 02 янв. 2017 г., 8:17:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dangerous93
02 янв. 2017 г., 11:11:38 (7 лет назад)

var
  a, d: real;
  i, n: integer;

begin
  write('Введите значение первого члена прогрессии, a=');
  readln(a);
  write('Введите значение разности прогрессии, d=');
  readln(d);
  write('Введите количество членов прогрессии, n=');
  readln(n);
  writeln('Значения членов прогрессии:');
  for i := 1 to n do
    write(a + d * (i - 1), ' ')
end.

Тестовое решение:

Введите значение первого члена прогрессии, a=4
Введите значение разности прогрессии, d=2
Введите количество членов прогрессии, n=6
Значения членов прогрессии:
4 6 8 10 12 14


Ответить

Другие вопросы из категории

Ребят пожалуйста помогите===Срочно=====!: Из пункта А в пункт Б, растояние между которыми 50км, одновременно выехали автомобилист и

велосипедист.Известно что в час автомобилист проезжает на 40км больше чем велосипедист.Определите скорость велосипедиста если известно что он прибыл в пункт Б на 4 часа позже автомобилиста.Ответ в км\ч

помогите плиз дайтн ответы

Читайте также

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

Составьте пожалуйста любую задачу на паскале с использованием цикла.

И пояснение к задаче,если можно.



Вы находитесь на странице вопроса "задача в паскале абс", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.