Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Почему программа на паскале не подставляет начальное значение x (x:=0), а подставляет сразу x+h? Т.е. в выводе ответов первым должно идти значение -1, а

10-11 класс

идет совсем другое. И как в таком случае реализовать это?
Код программы:
program program3;
uses crt;
var x, y, c, h:real;
begin
clrscr;
x:=0;
h:=0.4;
repeat x:=x+h;
y:=power(x,1/3)-1;
writeln (y);
until x>=4;
end.

Ydin204 31 янв. 2017 г., 13:30:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЮляшаМилаша
31 янв. 2017 г., 15:00:24 (7 лет назад)

Цикл начинается с того, что сразу же присваивает х значение 0.4, и после этого для у производятся вычисление исходя из х = 0.4. Чтобы х был изначально равен 0, нужно поменять местами строки в цикле, выглядит это так:

var
  x, y, h: real;
begin
  h := 0.4;
  repeat
     y := power(x, 1 / 3) - 1;
     x := x + h;
     writeln(y);
  until x >= 4;
end.

Здесь значение переменной у сначала будет равно результату вычисления, при котором х еще равен 0.
Строку x:=0; можно убрать, так как при объявлении переменной (в разделе var) ей присваивается 0 по умолчанию.
А также, есть лишняя переменная с.

+ 0 -
Belenikin
31 янв. 2017 г., 16:36:33 (7 лет назад)

Нужно поменять местами строки:
x:=x+h;
y:=power(x,1/3)-1;

Ответить

Другие вопросы из категории

ПОМОГИИИИТЕ

Даны три целых числа m, n, k. Проверьте, является ли, k остатком от деления m на n. Ответ дать в текстовой форме.

Читайте также

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

ПОМОГИТЕ ПОЖАЛУЙСТА!!! МОЖНО ТОЛЬКО ПРОГРАММУ. НЕ МОГУ РАЗОБРАТЬСЯ КАК СДЕЛАТЬ...

Составить программу на Паскале (желательно и выполнить).
С клавиатуры ввести 10 элементов массива (целые числа). Вывести исходный массив. Заменить элементы на противоположные и вывести получившийся массив (в строку).

Создать программу на Паскале.

Даны
действительные числа х, у, и z. Вычислить
max (x + y + z, xyz).

(только пожалуйста напишите полное решение, а не кусок)



Вы находитесь на странице вопроса "Почему программа на паскале не подставляет начальное значение x (x:=0), а подставляет сразу x+h? Т.е. в выводе ответов первым должно идти значение -1, а", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.