Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

сделайте пожалуйста срочно

5-9 класс

Svetlananestere 13 окт. 2014 г., 19:01:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Фролова1999
13 окт. 2014 г., 19:53:05 (9 лет назад)

вариант решения через if... then... else
var 
t: byte;
begin  Write('Vvedite vremya: '); 
Readln(t); 
if (t < 0) or (t > 24) then     
begin       
Writeln('Oshibka! Nevernyj vvod dannyh!');       
Readln;       
Exit;     
end;
if (t >= 0) and (t <= 10) then Writeln('Vy uzhe prosnulis?')
else if (t >= 13) and (t <= 15) then Writeln('Ne pora li obedat?')
else if (t >=18) and (t <= 24) then Writeln('Vecher i noch vperedi!')
else Writeln('Kak rabotaetsya?');
Readln;
end.

вариант решения через case...of
var 
t: byte;
begin 
Write('Vvedite vremya: '); 
Readln(t); 
if (t < 0) or (t > 24) then     
begin       
Writeln('Oshibka! Nevernyj vvod dannyh!');       
Readln;       
Exit;     
end;
case t of
0..10: Writeln('Vy uzhe prosnulis?');
13..15: Writeln('Ne pora li obedat?');
18..24: Writeln('Vecher i noch vperedi!')
else Writeln('Kak rabotaetsya?');
end;
Readln;
end.

Ответить

Другие вопросы из категории

Пожалуйста, помогите! Если я не сделаю это задание, мне придется сдавать сложнейший экзамен. Пожалуйста!

Написать программу ввода четырех целых чисел и вычисления их среднего арифметического. Протестировать программу на различных исходных данных (включая вещественные числа) и доказать правильность ее работы.

1) В школьной столовой предлагаются два блюда: салат и макароны с котлетой. Сколько битов несет сообщение о том, что ученик выбрал себе макароны с

котлетой?

2)Сколько бит информации содержит сообщение состоящее из 5 символов при использовании алфавита состоящего из 64 символов?

3) Реферат учащегося имеет объем 20 Кбайт, каждая страница содержит 32 строки по 64 символа. Мощность алфавита 256. Сколько страниц в реферате?

Читайте также

сделайте пожалуйста, срочно надо!

http://fizinf.ucoz.ru/document/tablica.doc

Помогите сделать пожалуйста Очень срочно!

Информатика 8 класс.

Помогите сделать пожалуйста Очень срочно!

Информатика 8 класс.

ПОМОГИТЕ, НАПИСАТЬ КОРОТКИЙ АЛГОРИТМ, ЧТОБЫ РОБОТ СДЕЛАЛ РИСУНОК КАК В ЗАДАНИИ №2

СДЕЛАЙТЕ, ПОЖАЛУЙСТА, ТОЛЬКО ВТОРОЙ НОМЕР!!!



Вы находитесь на странице вопроса "сделайте пожалуйста срочно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.