Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Известны длины сторон двух прямоугольников. Вычислить Площади прямоугольников и сравнить их .Определить,является ли прямоугольники квадратами. Выясни

10-11 класс

ть поместится ли один прямоугольник внутрь другого. ( Программный код нужно писать в Паскале!)

СальгинА 08 сент. 2016 г., 0:59:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Azhara2014
08 сент. 2016 г., 2:54:31 (7 лет назад)

program gt;
var a,b,c,d:integer;
begin
read(a,b,c,d);
if(a=b)then writeln('ПРЯМОУГОЛЬНИК ПОД НОМЕРОМ 1 ЯВ.. КВАДратом');
 if(c=d)then writeln('ПРЯМОУГОЛЬНИК ПОД НОМЕРОМ 2 ЯВ.. КВАДратом');
if((a<=c)and(b<=d))or ((a<=d)and(b<=c)) or((a>=c)and(b>=d)) or((a>=d)and(b>=c))then writeln('ДА')else writeln('НЕТ');
end. 

Ответить

Другие вопросы из категории

1) Одномерный массив из 6 элементов заполнить случайным образом числами от 5 до 17. Поменять местами 5-ый и 7-ой элементы массива, а 4-ый элемент

увеличить в 3 раза. Вывести на экран монитора первоначальный и преобразованный массивы в строчку.

Пожалуйста, помогите составить программу массива.

Определите, что будет напечатано в результате работы следующего фрагмента программы:

var k, s: integer;
begin
s:=0;
k:=0;
while s < 80 do begin
s:=s+2*k;
k:=k+4;
end;
write(s);
end.

100 б. В лотерее разыгрывалось 64 шара.

Выигрышная комбинация состояла из N шаров. Сообщение о ней несет 42 бита информации. N=?
Тема задачи: Количество информации. Формулы Хартли и Шеннона

Читайте также

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Помогите пожалуйста!!

1) Ввести с клавиатуры стороны прямоугольника, вычислить площадь и вывести её на экран.
2) Ввести 2 числа. Определить являются ли они противоположными.



Вы находитесь на странице вопроса "Известны длины сторон двух прямоугольников. Вычислить Площади прямоугольников и сравнить их .Определить,является ли прямоугольники квадратами. Выясни", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.