Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составьте

5-9 класс

программу, которая заполняет массив a [1..10] случайными целыми числами в

BAbeli 31 окт. 2014 г., 13:37:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Devoid
31 окт. 2014 г., 15:01:54 (9 лет назад)

uses crt;
program new;
var a:array[1..10] of integer;i:integer;
begin
clrscr;
randomize;
for i=1 to 10 do begin
a[i]:=random(10)+1
end;
for i=1 to 10 do begin
write(a[i]:3)
end;
writeln;
for i=1 to 10 do begin
if a[i] mod 2 = 0 then a[i]:=a[i]*2
else a[i]:=a[i]*3
end;
for i=1 to 10 do begin
write(a[i]:3);
end;
readln;
end.

Ответить

Другие вопросы из категории

Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и меняет местами значения первого и последнего элементов

массива.На экран выводятся исходные и преобразованные значения.Надо очень СРОЧНО!!!!!!!!!!!!!!!!!!!!!!

Ребят,ОЧЕНЬ ОЧЕНЬ СРОЧНО!! хотя бы три решите 1 задача.

Какое количество информации требуется для кодировки Азбуки Морзе?

Задача 2.
Имеется монохромная фотография, информационный обьем которой 1000 байт, и высотой 80 пикселей. Во сколько раз уменьшится ее информационный обьем, если уменьшить ее ширину на 90 пикселей?

Задача 3.
Сколько дискет понадобится для копирования файла обьемом 11,5 Гигабайт? (Дополнительный балл: определить высоту стопки этих дискет в сантиметрах).

Задача 4.
Определите информационный обьем задачи: Ехал поезд из четырёх вагонов. Два спереди и один сзади. В среднем вагоне ехал брюнет, а в первом блондин. Решил блондин перейти в последний вагон, а рыжий в первый. Каждый двигался со скоростью два км в час. Скорость поезда никак не влияла на их самочувствие. Сколько времени им понадобится, чтобы одновременно посмотреть в глаза красавице в среднем вагоне? Кого она выберет в попутчики?

Задача 5.
Имеется коробка размером 25x20x30 сантиметров. Определите ее информационный обьем.

Читайте также

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3 2)даны действительные числа x и y. необходимо определить

принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1).

3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P.

cрочно надо на языке паскаль составить плиз)



Вы находитесь на странице вопроса "составьте", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.