Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Заполнить массив величинами роста учеников в классе. При чем рост девочек вводить как положительное число, а рост мальчиков как отрицательное. Чей средний

10-11 класс

рост больше?

школа18 10 сент. 2016 г., 5:08:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikaobninsk
10 сент. 2016 г., 6:04:30 (7 лет назад)

const n=9;
var a:array [0..n] of double; 
  i,gi,mi:Integer; 
 m,g:Double;
begin 
g:=0; 
m:=0; 
 gi:=0; 
mi:=0; 
 for i:=0 to n do 
  readln(a[i]); 
 for i:=0 to n do 
  begin   
 if a[i]>0 then 
     begin   
   Inc(gi);     
 g:=g+a[i]; 
    end;   
  if a[i]<0 then
     begin   
  Inc(mi); 
    m:=m+abs(a[i]);
     end; 
 end; 
  g:=g/gi;
   m:=m/mi; 
  if m>g then
    Writeln('Men') 
  else if g>m then 
 Writeln('Girl'); 
  if m=g then 
   Writeln('=');
 readln;
end.

Ответить

Другие вопросы из категории

Обчисліть скільки часу потрібно для передавання

відеокліпу об'ємом 160 Мб за допомогою мо­дему зі швидкістю 800 Кбіт/с.

Дан одномерный массив. Записать массив в обратном порядке без использования дополнительного массива.

Составить блок-схему и программу в Паскале.

Читайте также

(Программа Паскаль) 1)Заполните массив элементами арифметической прогрессии. Её первый элемент и разность нужно ввести с клавиатуры. 2)

Заполните массив степенями числа 2( от 2(в первой степени) до 2(в N степени)

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "Заполнить массив величинами роста учеников в классе. При чем рост девочек вводить как положительное число, а рост мальчиков как отрицательное. Чей средний", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.