Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Очень срочно! Решите пожалуйста следующие задачи в Turbo Pascal 1) Вывести на экран все нечетные числа от 100 до N ? 2) определите

5-9 класс

является ли произвольное число N совершенным ?

3) вывести таблицу умножаения для чисел от 1 до 9

Заранее всем спасибо!!!!!

99661996 02 июля 2015 г., 11:21:08 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lovekillsxx
02 июля 2015 г., 13:57:21 (8 лет назад)

1)

program OddNums;

var 

i,N: word;

begin

 readln(N);

 for i:=100 to N do if ((i mod 2) = 1) then writeln(i);

end.

 

2) Если я правильно понимаю понятие "совершенные числа"...

program PerfectNums;

var 

i,N,sum: word;

begin

 readln(N);

 sum:=0;

 for i:=1 to N-1 do if ((N mod i) = 0) then sum:=sum+i;

 if sum=N then writeln ('YES') else writeln ('NO');

end.

 

3) program MultTable

var

 i,j: integer;

begin

 for i:=1 to 9 do begin

  for j:=1 to 9 do writeln(i,' x ',j,' = ', i*j);

  writeln;

 end;

end.

Ответить

Другие вопросы из категории

Помогите плиз решить задачи.

1)Каникулы в школе птиц и зверей начались большим карнавалом. Медведь, волк, лиса и заяц явились в маскарадных костюмах волка, медведя, лисы и зайца. на балу зверь в маскарадном костюме зайца выиграл банку меда и остался этим очень не доволен. Известно также, что медведь не любит лису и никогда не берет в лапы картинок, где она нарисована. Зверь в маскарадном костюме лисы выиграл в лотерею пучок моркови. Но это не доставила ему не какой радости. Не могли бы вы сказать, какой маскарадный костюм смастерил себе каждый из зверей.
2)Барсук позвал к себе гостей:
Медведя, рысь и белку.
И подарили барсуку
Подсвечник и тарелку.
Когда же он позвал к себе Рысь, белку, мышку, волка,
о он в подарок получил подсвечник и иголку.
Им были вновь приглашены
волк, мышка и овечка.
И получил в подарок он
Иголку и колечко.
Он снова пригласил овцу,
Медведя, Волка белку
Колечко и тарелку.
Нам срочно нужен ваш совет.
(На миг дела отбросьте.)
Хотим понять, Какой предмет
Каким подарен гостем,
И кто из шестерых гостей
Явился без подарка?
Не можем мы сообразить,
Сидим... Мудрим... Запарка...

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

Читайте также

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!



Вы находитесь на странице вопроса "Очень срочно! Решите пожалуйста следующие задачи в Turbo Pascal 1) Вывести на экран все нечетные числа от 100 до N ? 2) определите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.