Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуста.задача-введите с клавиатуры n чисел.вывести на экран колечество чисел превосходящих первое число.я пишу- begin

10-11 класс

ClrScr;
k:=0;
for i:=1 to n do begin
write(введите число'); readln(n);
end;
for i:=1 to n do begin
if m[i]>m[1] then k:=k+1;
end;
write(' чисел превосходящих первое число- ',k); у меня всегда выводит 0

Lehas228 30 июля 2016 г., 5:41:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hata19971
30 июля 2016 г., 8:27:00 (7 лет назад)

program zadacha;
var   
   k,x,i,n:integer;   
   m:Array[1..100] of Integer;
begin   
  k:=0;   
  readln(n);   
  for i:=1 to n do begin       
     readln(m[i]);   
  end;   
  for i:=2 to n do begin
        if m[i]>m[1] then k:=k+1;
    end;
    write(k);
end.

Ответить

Другие вопросы из категории

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива



Вы находитесь на странице вопроса "помогите пожалуста.задача-введите с клавиатуры n чисел.вывести на экран колечество чисел превосходящих первое число.я пишу- begin", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.