Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

помогите. напишите программу на с++ для вычисления площяди ромба или квадрата

10-11 класс

Lizamur1 13 окт. 2016 г., 7:57:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shkhzik
13 окт. 2016 г., 10:32:01 (7 лет назад)

Для квадрата:

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

double area(double);

int main()
{
   double side;

   cout << "Enter the square side: "; //Введите сторону квадрата
   cin >> side;

   cout << "Area of a square = " << area(side) << endl;

   cin.get();
   return 0;
}

double area(double side)
{
   return side * side;
}

Ответить

Другие вопросы из категории

Метеорологическая станция ведет наблюдения за влажностью воздуха. Результатом одного измерения является число от 0 до 100 (%), которое записывается при

помощи минимально возможного количества битов. Станция сделала 80 измерений. Определите информационный объем результатов наблюдений.

1) 30 битов 3) 210 битов

2) 21 байт 4) 168 байтов

Procedure TFrmCalc.BtnPlusClick(Sender: TObject);

begin FrmCalc.LblPlus.Visible:=True;
FrmCalc.LblMinus.Visible:=False;
FrmCalc.LblDel.Visible:=False;
FrmCalc.LblUmn.Visible:=False;
FrmCalc.LblA.Caption:=(StrToInt(FrmCalc.EdtCh1.Text)+StrToInt(FrmCalc.EdtCh2.Text));
end;

Выдает ошибку :
Error: Incompatible type for arg no. 1: Got "LongInt", expected "TTranslateString"

Подскажите кто-нибудь , В чем ошибка (?), Ставил IntToStr , только тип Float не пробовал .

Определите среднюю скорость передачи данных канала (кб/с), если три файла, один размером 4 Мб и второй – 8 Мб, а третий 836Кб скачивались

одновременно в течение 6 минут. Ответ округлите по математическим правилам с точностью до целых чисел. В ответе введите только число без единиц измерения

Помогите,пожалуйста. 1.Приведите примеры перехода от порядка к хаосу (Помогите,пожалуйста.1.Приведите примеры перехода от порядка к хаосу

(уменьшение информации) в окружающем мире.2.Приведите примеры перехода от хаоса к порядку (увеличение информации) в окружающем мире.3.Каковы должны быть свойства информации,представленной в форме сообщений.4.Каковы должны быть свойства информации,прдставленные в форме знаний.5.Приведте примеры систем управлений техническими устройствами.6.Приведите примеры информационных сообщений,которые несут 1бит информаци

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Помогите написать программу на с++.

Напишите функцию, которая вычисляет значение ab. Числа a и b могут быть любыми дробными положительными числами. И программу, использующую эту функцию для вывода результата на экран.



Вы находитесь на странице вопроса "помогите. напишите программу на с++ для вычисления площяди ромба или квадрата", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.