Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Выведите число 2^N(в степени N). N не превосходит 30

5-9 класс

Арифметика 01 марта 2015 г., 13:14:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Кнежна
01 марта 2015 г., 15:59:14 (9 лет назад)

var

n:byte;

begin

repeat

write ('N = ');readln(n);

until (n<=30);

writeln (exp(n*ln(2)):0:0);

readln;

end. 

 

+ 0 -
Saba2234
01 марта 2015 г., 17:12:09 (9 лет назад)

Program outlaw;
uses crt;
var
  n: real;
begin
  write('Введите число N ');
  readln(n);
  writeln('*** alphaues is thinking... ***');
  if N<=30 then
    writeln('2 в степени N равнo ',power(2,n))
  else  writeln('N>30, введите другое число!!!')
end.

Ответить

Другие вопросы из категории

помогите решить задачу по информатике

дано 4-ех значное число. Поменять 1 и 3 число местами

Закончите предложение (дайте наиболее полный ответ) "Компьютер - это ..."

1.электронный прибор с клавиатурой и экраном
2. устройство для выполнения вычислений
3. универсальное программно управляемое устройство для обработки, хранения и передачи информации
4. электронное устройство для создания текстовых и графических документов
ПОМОГИТЕ! ПРОШУ.....

Ребят, помогите, напишите с решанием

Читайте также

В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а

затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ
Одно целое положительное число, не превышающее 1000. Одно целое положительное число, не превышающее 1000. ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число. На языке С

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных

данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

На сковородку одновременно можно положить k котлет. Каждую котлету нужно с каждой стороны обжаривать 1 минуту непрерывно. За какое наименьшее время

удастся поджарить с обеих сторон n котлет?

Входные данные:
Вводятся 2 числа: k и n. Все числа не превосходят 32000.

Выходные данные:
Выведите одно число – ответ на задачу.



Вы находитесь на странице вопроса "Выведите число 2^N(в степени N). N не превосходит 30", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.