Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль! Автоматически задается массив, сост. из 20 элементов. Все четные элементы заменить нулями. Нули поставить в конец массива. Помогите!!! Я уже

5-9 класс

заменила все четные, поняла сам процесс, как их поставить в конец, но не соображу, как правильнее записать. !!!

Opanasenkosof 10 янв. 2014 г., 12:58:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Niuta201
10 янв. 2014 г., 14:53:53 (10 лет назад)

program P1;
uses
crt;
var
mas : array[1..20] of integer;
i,j,k : integer;
tmp : string;
begin

clrscr;

writeln('Start array: ');

for i := 1 to 20 do
begin

mas[i] := random(100);

write(mas[i],' ');

end;


for i := 1 to 20 do
begin

if mas[i] mod 2 = 0 then
mas[i] := 0;

end;

 

for i := 1 to 20 do
begin

if mas[i] = 0 then
begin

for j := 20 downto i do
if mas[j] <> 0 then
begin

k := mas[j];
mas[j] := mas[i];
mas[i] := k;

end;

end;

end;


writeln('');
writeln('Result array: ');

for i := 1 to 20 do
write(mas[i],' ');


readln(tmp);
read(tmp);


end.

Ответить

Другие вопросы из категории

Что называется алгоритмом????

ПОМОГИТЕ СРОЧНО ПРОЩУ ВАС НЕ ПРОЙДИТЕ МИМА!!!!!

1)Для наглядного представления площадей крупнейших государств мира целесообразно использовать:

а)круговую диаграмму
б)график
в)столбчатую диаграмму
г)ярусную диаграмму
2)Для наглядного представления изменения температуры воздуха в течение месяца следует использовать:
а)круговую диаграмму
б)график
в)столбчатую диаграмму
г)ярусную диаграмму

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Дан одномерный массив B из N элементов, значения которых находятся в диапозоне от 0 до 325.

1) Заменить все чётные элементы на их номера. Вывести на экран исходный и новый массив.
2) Заменить все чётные элементы, стоящие на нечетных местах, на их номера.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Паскаль! Автоматически задается массив, сост. из 20 элементов. Все четные элементы заменить нулями. Нули поставить в конец массива. Помогите!!! Я уже", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.