Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан одномерный массив B из N элементов, значения которых находятся в диапозоне от 0 до 325.

5-9 класс

1) Заменить все чётные элементы на их номера. Вывести на экран исходный и новый массив.
2) Заменить все чётные элементы, стоящие на нечетных местах, на их номера.

Evenlol 22 июля 2014 г., 1:39:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ксеня29
22 июля 2014 г., 3:25:08 (9 лет назад)

1) program X;
var 
B:array [0..325] of integer;
i,g,n:integer;
Begin
write ('Введите количество элементов массива = ');
read(n);
For i:= 1 to n do
  Begin 
 B[i]:= -10+random(25);
 write (B[i]:4);
 end;
 writeln;
 writeln('новый массив');
  begin
   for i:=1 to n do 
if B[i] mod 2=0    then 
begin 
g:=i; 
B[i]:=g; 
   write (B[i]:4);
 end;
 end; 
    End.

2) 

+ 0 -
Kristina220120
22 июля 2014 г., 6:09:04 (9 лет назад)

а первое и второе задание должны быть в одной программе?

Ответить

Другие вопросы из категории

Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. Измените что надо сайт не пропускает. var

i,n,t,k:Inteer;
begin
write('n:=');readln(n);
for i:=1 to n do begin
write(i,'-> ');readln(t);
if t=0 then inc(k);
end;
writeln(k);
end.

Очень срочно!!!!! Определить сколько книг поместиться на лазерном диске объем 700 Мбайт, если известно, что книга

состоит из 150 страниц, на каждой странице 40 строк в каждой строке по 60 символов?(Один символ имеет информационный объем 1 байт) Только всё надо разъяснить!!!!

Для данного x вычислить значение функции

корень из 5x+3, если x>=13
F(x)= 4x+3\x-5x^2, если x<-13

-

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

imax:=1 for i:=2 to 10 do if a [i]>a [imax] then imax:=i; write ('Наибольший элемнт a[', imax, ' ]=', a[imax])

самостоятельно запишите программу, в которой осуществляется формирование целочисленного массива a из 10 элементов значения которых лежат в диапозоне от 0 до 99,и поиск наибольшего элемента этого массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

. Дан массив, содержащий 2014 положительных целых чисел. Напишите на одном из языков программирования программу, которая находит в этом массиве количество

элементов, значение которых более чем в два раза превосходит значение предшествующего элемента. Например, для массива из 6 элементов, содержащего числа 2, 5, 10, 15, 40, 100, программа должна выдать ответ 3 (условию соответствуют элементы со значениями 5, 40 и 100). Программа должна вывести общее количество подходящих элементов, значения элементов выводить не нужно. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из описанных переменных.
Паскаль Алгоритмический язык
const N = 2014;
var a: array [1..N] of integer;
i, j, k: integer;
begin
for i:=1 to N do
readln(a[i]);

end. алг
нач
цел N=2014
целтаб a[1:N]
цел i, j, k
нц для i от 1 до N
ввод a[i]
кц

кон


4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Дан одномерный массив B из N элементов, значения которых находятся в диапозоне от 0 до 325.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.