Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

imax:=1 for i:=2 to 10 do if a [i]>a [imax] then imax:=i; write ('Наибольший элемнт a[', imax, ' ]=', a[imax])

5-9 класс

самостоятельно запишите программу, в которой осуществляется формирование целочисленного массива a из 10 элементов значения которых лежат в диапозоне от 0 до 99,и поиск наибольшего элемента этого массива.

AlekseevaNatalalii 16 мая 2014 г., 11:34:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Masha7525
16 мая 2014 г., 13:49:42 (9 лет назад)

как я поняла, нужно было использовать кусок кода, данный выше?

var  
a: array[1..10] of integer; 
imax, i: byte;
begin 
Writeln('Массив:'); 
Randomize; 
for i:=1 to 10 do   
begin     
a[i]:=Random(100);     
write(a[i]:4);   
end; 
imax := 1; 
for i:=2 to 10 do   
if a[i] > a[imax] then imax := i; 
writeln; 
writeln('Максимальный элемент = ', a[imax]:3, ' в позиции ', imax:2);
end.

Ответить

Другие вопросы из категории

с 54 упр. 25 7.роман- поэма= стихотворение-... а)поэма б)рифма в)строфа г)жанр 9.север- юг= осадки... а)пустыня б)полюс в)дождь г)засуха 12.

слагаемое-сумма=множитель-... а)произведение б)частное в)разность г)умножение

Среди чисел a, b, c определить количество чисел кратных 3.

Помогите, пожалуйста, написать программу для Turbo Pascal или просто алгоритм.

то что отмечено карандашом

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

var k,m : integer; Dat [1]:=12; Dat [2]:=15; Dat [3]:=17; Dat [4]:=15; Dat [5]:=14; Dat [6]:=12; Dat [7]:=10; Dat

[8]:=13;

Dat [9]:=14; Dat [10]:=15;

m:=0;

for k :=1 to 10 do

if Dat [k]>12 then

begin

m:=Dat [k]

end;

writeln(m);

End.

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

Значение двух массивов А {1..100} и B {1..100} задаются с помощью следующего фрагмента программы:for n:=1 to 100 do A

{n} := (n-80)*(n-80);

for n:=1 to 100 do

B {101-n} :=A {n};

Какой элемент массива В будет наибольшим?

1) В {1} 2) B {21} 3) B {80} 4) B {100}

Var k, m: integer; Dat: array[1..10] of integer; Begin Dat[1] := 16; Dat[2] := 20; Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 11;

Dat[9] := 15; Dat[10] := 35;

m := 50;

for k := 1 to 10 do

if Dat[k]<m then

begin

m := Dat[k]

end;

writeln(m);

End.



Вы находитесь на странице вопроса "imax:=1 for i:=2 to 10 do if a [i]&gt;a [imax] then imax:=i; write ('Наибольший элемнт a[', imax, ' ]=', a[imax])", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.